2017 R1

Configuring a Work StationPermanent link for this heading

Installing the Mozilla Thunderbird ButtonsPermanent link for this heading

The use of Mozilla Thunderbird buttons requires the installation of the Fabasoft Folio Client for Mozilla Thunderbird (additionally to the Fabasoft Folio Client). The following XPI package for Mozilla Thunderbird has to be installed on the client depending on the operating system:

  • Setup\ComponentsWeb\Client\FolioClientThunderbirdWin32PM.xpi (Microsoft Windows)
  • Setup\ComponentsWeb\Client\FolioClientThunderbirdLnx32PM.xpi (Linux)

To install the XPI package, perform the following steps:

  1. Open Mozilla Thunderbird.
  2. Open the “Tools” menu and click “Add-ons”.
  3. Click “Tools for all add-ons” and then click “Install Add-on From File”.
  4. Select the XPI package in the file system and click “Open”.
  5. Click “Install Now”.
    Note: If you get an error that the Signing could not be verified, perform the steps as described in chapter “Enable the Verification on Certificate”.

Enable the Verification on CertificatePermanent link for this heading

If you get following warning during the installation process, perform the steps as described in this chapter and install the XPI package again.

  1. Open the “Tools” menu and click “Options”.
  2. Under the “Advanced” category click the “Certificates” tab.
  3. Click “View Certificates”.
  4. Click the “Authorities” tab and select the “VeriSign Class 3 Public Primary Certification Authority - G5”.
  5. Click “Edit” and check “This certificate can identify software makers.”
  6. Click “OK” three times to close all windows.

Now you can install the XPI package as described in chapter “Installing the Mozilla Thunderbird Buttons”.

Microsoft Windows RegistryPermanent link for this heading

Make sure that the Mozilla Thunderbird button entries are available in the Microsoft Windows Registry. The entries (with FSCVAPP@1.1001:importsource==11) are written into the Microsoft Windows Registry of the work station when connecting to a Fabasoft Folio Domain with the Fabasoft Folio Web Client.

HKEY_CURRENT_USER\Software\Fabasoft\WebClient\ConfigValues

Configuring the Mozilla Thunderbird ClientPermanent link for this heading

To be able to use the Mozilla Thunderbird buttons, the buttons first have to be added in Mozilla Thunderbird. Perform the following steps:

  1. Click “Tools” > “Add-ons”. On the “Extensions” tab the “Fabasoft Folio Client for Mozilla Thunderbird” is listed.
    Note: If the entry does not exist, the “Fabasoft Folio Client for Mozilla Thunderbird” has to be installed (see chapter “Installing the Mozilla Thunderbird Buttons”).
  2. Click “Options”. In the Connection URL field specify the connection URL of the server and the virtual directory where to a connection should be established:
    http://<server name>/<virtual directory>
  3. Click “OK” and close the “Add-ons” window.
  4. To be able to view the buttons, the “Fabasoft Folio” tool bar has to be shown in Mozilla Thunderbird. Use the “View” > “Toolbars” menu and choose “Customize”.
  5. The “Customize Toolbar” window is opened. The “Fabasoft Folio” tool bar can be attached by drag-and-drop. Place the tool bar in a desired position.