2019 Update Rollup 1

Fabasoft Folio 2019Permanent link for this heading

Find out more about new features and improvements of Fabasoft Folio 2019. Unless otherwise stated the described features and improvements are available in following editions:

  • Fabasoft Folio Enterprise
  • Fabasoft Folio Compliance
  • Fabasoft Folio Governance

The New User InterfacePermanent link for this heading

With Fabasoft Folio 2019 you get the new user interface. Have a look at the following tips for a smooth switching.

Structure of the Fabasoft Folio Web Client

The Fabasoft Folio Web Client offers you an intuitive, easy-to-learn and individually customizable user interface that enables you to efficiently complete your daily tasks.

The web client is divided into the following areas:

  • home (starting page)
  • top bar
  • tool area
  • title bar
  • menu bar (hidden by default)
  • content area

The New Home Area

The newly designed home area offers you a better overview and a wide range of customization options.

The dashboard concept of the home area allows you to show or hide widgets, change their size and move them.

  • Personal Folder
    In your personal folder, you can store documents, folders and Teamrooms that are important for you.
  • Teamrooms Shared With Me
    Contains all Teamrooms in which you are authorized as a team member. Teamrooms that you have created yourself are excluded from this list. For a better overview, the list is structured by years and months. Via the “Integrate in My Folder Hierarchy” action, you can add the desired Teamrooms to your personal folder, to your favorites or directly to “Home”.
  • Favorites
    Favorites allow you to quickly access objects that you need repeatedly.
  • Worklist
    Shows your worklist.
  • History
    Contains the most recently used objects and most recently sent e-mails.
  • Follow-Ups
    Contains your follow-ups that that fall within the period you defined.
  • Other Dashboards
    Apps that offer their own dashboards are also displayed directly on “Home”.

Customizing the Home Area Individually

The following options are available for customizing your home area:

  • Show or hide widgets
    The “View” menu allows you to show or hide widgets.
  • Moving or resizing widgets
    You can move widgets using drag-and-drop or the context menu. You can also specify the size in the context menu of the widget.
  • Storing objects on “Home”
    In addition to the widgets, you can also copy and paste important objects directly to “Home”.
  • In the basic settings under accessibility, you can specify whether background images are to be displayed in the Show Background Images in Dashboards and Home field.

Quick Access

The “Quick Access” button on the far right of the top bar allows you to open the “Home” dashboard view and navigate to the respective element by clicking on it.

Keyboard Shortcuts

The elements on “Home” can be selected directly using the following keyboard shortcuts, depending on the web browser. If several elements have the same initial letter, the behavior depends on the web browser (navigation in an element or selection of an element).

Microsoft Windows

  • Microsoft Internet Explorer: Alt + First Letter
  • Google Chrome; Alt + First Letter
  • Mozilla Firefox: Alt + Shift + First Letter

Apple macOS

  • Apple Safari: Ctrl + Alt + First Letter
  • Google Chrome: Ctrl + Alt + First Letter
  • Mozilla Firefox: Ctrl + Alt + First Letter

Linux

  • Mozilla Firefox: Alt + Shift + First Letter

Top Bar

In the top bar, you will find your logo on the left and the account menu (your user name), the role button, the support button, the logout button, the quick access button, the home button and the search field on the right.

Note: The buttons displayed depend on the configuration of your Folio installation.

Tool Area

The tool area is available in all widgets, but not directly on “Home”.

The context-independent tools “Tree View” and “Favorites” can be opened or closed via a quick selection. The “Actions” (e.g. “Upload”) are always at your disposal. Depending on the context, different actions are offered to you.

Up to three tool areas can be displayed next to each other (e.g. “Tree View”, “Actions” and “Team”). The tree view can be enlarged to make it easier to read even longer entries.

Tree View

Objects that have an object list property are displayed hierarchically in the tree view. These are, for example, folders that can contain additional folders or documents. Clicking an object in the tree view displays the object list of the corresponding object in the content area.

Favorites

You can add frequently used objects (for example, Teamrooms or documents) to your favorites. To do so, navigate to the desired object. It is offered in the “Favorites” tool for adding.

Actions

The “Actions” tool area contains important actions that are valid in the current context.

Title Bar

The title bar contains the breadcrumbs of the currently opened hierarchy. Clicking on a breadcrumb takes you to the corresponding object. By right clicking the context menu of the object can be opened.

If you navigate in a widget, all other widgets of the same level are display as tabs.

Menu Bar

Menu commands are offered via the menu bar (hidden by default). Menu commands can either be context-independent (e.g. “User Settings”), refer to the object displayed in the content area (e.g. “New”) or to the objects selected in the content area (e.g. “Rename”).

To display the menu bar, proceed as follows:

  1. Click the account menu (your user name) and then click “Basic Settings”.
  2. Select the “Show Menu Bar” option.
  3. Click “Save”.

Content Area

The content area displays the content of the current object. This can be the content of a folder or the preview of a document, for example. The top level is called “Home”.

Double Click

So far objects were opened with a double click and marked by a single click. In the new interface, there exist – as usual for web interfaces – no more double clicks. A single click opens the object and a selection is carried out via a checkbox.

To open a document in a third-party product, you can switch to the content view by clicking on the document, and then click the “Edit” or “Read” action in the tool area. Alternatively, you can execute the commands from the context menu (right click).

For renaming select an entry and press "F2" or execute the context menu command "Rename".

Image Gallery

Have a look at the image gallery to get an impression of the new design.

Image 1: View of a folder

Image 2: Opened tree view

Image 3: Mobile device

FormsPermanent link for this heading

The options available to you when creating user-defined forms have been massively expanded.

Form Editor

With the graphical form editor, you can create new forms with drag-and-drop and extend objects with new properties without programming knowledge.

The form editor has been completely reworked and now fits seamlessly into the familiar user interface. In addition, the accessibility is ensured and can therefore be easily operated by blind users.

Form Fields

You can use the following form fields on your form:

  • Input Field
    A single-valued field of a particular type (e.g. string, date or object).
  • Item List
    A list of fields of a particular type (e.g. string, date or object)
  • Multiline Text
    A multi-valued field of type string.
  • Check Box
    One or more check boxes (multiple selection is possible).
  • Radio Buttons
    One value can be selected from several values with radio buttons.
  • Combo Box
    One value can be selected from several values in a drop-down box.
  • Standard Property
    Provides the ability to display standard properties of objects on the user-defined form.
  • Separator
    Used to structure related properties.
  • HTML Text
    Allows providing formatted descriptions on the form.

Types

You can define the following types for input fields and item lists:

  • String
  • Integer
  • Float
  • Date
  • Date and Time
  • Timespan
  • Numerator
  • Hyperlink
  • Currency
  • Object

Note: The type of a field cannot be changed after the form is published.

Additional Settings

Depending on the type, you can make further settings for form fields. In general, you can specify:

“General” tab

  • Required field
  • Help text
  • Initialization value

“Advanced” tab

  • Programming name
  • Readability or changeability depending on user rights
  • Calculations that influence the behavior (e.g., calculate the visibility of the field)

Multilingualism

For the languages ​​available in Fabasoft Folio, you can provide translations for the names and context-sensitive help. To do so, open the properties of the form (context menu command “Properties”) and switch to the “Translations” tab. For each multilingual name of the form you will find a corresponding entry.

Category

When you create a user-defined form, you can change the Applicable for field of the corresponding category. For example, if you want to restrict a BPMN process to such a category and use activities that are allowed only for documents, you can customize the category accordingly.

WorkflowPermanent link for this heading

The workflow provides following new features.

Better Overview in the WorklistPermanent link for this heading

In the worklist dashboard, in the to do list also the concerned objects are displayed beside the activity. In addition the concerned objects are listed in an own area.

Process FlowPermanent link for this heading

The workflow allows users to be included in the editing of business objects using processes. Processes consist of individual activities that can be processed in the worklist.

The “Processes” tab is available for objects on which at least one process has been started so that you can easily follow the process flow. An overview of the activities already executed and the current activity is displayed for each process.

Click on the process name to display the complete process with any loops and conditions. The process flow that has already been executed is indicated by bold lines. Paths that were not traversed are visualized with dashed lines.

You can use the context menu of the process elements to execute the commands allowed in each case. For example, if you have the appropriate rights, you can change the participant of an activity that has not yet been executed using the “Edit” context menu command.

Process StatisticsPermanent link for this heading

To obtain an overview of the running processes, several process statistics are available that illuminate the individual aspects of process execution.

Note: The settings can be configured for groups on the “Workflow” tab.

The statistics can be displayed for:

  • Process Administrators
    Provides an overview of all predefined and ad hoc processes of the organization.
  • Process Owners
    Provides an overview of all predefined processes for which the user is defined as the process owner.

Note: The process owner can be defined on the “BPMN Process Diagram” tab of a BPMN process diagram.

You access the process statistics via your worklist. The statistics are available for the following three levels: general overview, process definition and specific process.

General Overview

  • Process Statistics
    Provides an overview of the number of running processes and delayed processes.
  • Process Throughput
    Shows the number of started and completed processes and their difference in the selected time period.
  • Running Processes
    Shows the number of running processes and their changes in the selected time period.
  • Running Processes per Process Definition
    Shows the percentage breakdown of the process definitions of the running processes.
  • Activities of Running Processes
    Shows the percentage breakdown of the status of the activities of the running processes.
  • Delayed Activities
    Shows the percentage breakdown of the activities of the delayed processes.
  • Start Date of Running Processes
    Shows the number of running processes grouped by the start date in the selected time period.
  • Due Date of Activities
    Shows the activities of the running processes that need to be processed in the next two weeks.

Based on a Process Definition

  • Process Throughput
    Shows the number of started and completed processes and their difference in the selected time period.
  • Running Processes
    Shows the number of running processes and their changes in the selected time period.
  • Activities of Running Processes
    Shows the percentage breakdown of the status of the activities of the running processes.
  • Delayed Activities
    Shows the percentage breakdown of the activities of the delayed processes.
  • Start Date of Running Processes
    Shows the number of running processes grouped by the start date in the selected time period.
  • Due Date of Activities
    Shows the activities of the running processes that need to be processed in the next two weeks.
  • Processes
    Displays all processes (including completed processes) of the process definition.

Based on a Process

  • Runtime
    Shows the runtime of the process in days compared to the average runtime of the underlying process definition.
  • Activities
    Shows the percentage breakdown of the status of the process's activities.
  • Overview
    Shows the most important metadata of the process.

Note: The “Settings” action can be used to define the time period (from last week to last year) of the time-dependent statistics.

Working With BPMN 2.0Permanent link for this heading

Fabasoft Folio supports the international standard BPMN 2.0 (Business Process Model and Notation) for business process modeling. In addition to the renewed BPMN editor that allows you a simple graphical modeling, you can directly execute the business processes with the workflow engine. You get a tailored to your business workflow, without having to program a single line.

Multi-Instance ActivitiesPermanent link for this heading

Multi-instance activities can be used for processing an activity sequential or parallel by several process participants. You can use multi-instance activities in pre-defined processes and ad-hoc processes. This allows you, for example, to realize a parallel approval by several users.

Predefined Process (BPMN Editor)

In the BPMN editor, you can specify the loop type of a task.

  • None
    From the defined activity, one instance is created, which is offered to the defined process participants in the worklist. The first process participant, starting the processing, takes over the activity. The activity will be removed from all other worklists.
  • MI Parallel
    From the defined activity, one instance is created for each defined process participant and stored parallel in the respective worklists. All process participants must process the activity.
  • MI Sequential
    From the defined activity, one instance is created for each defined process participant and stored sequentially in the respective worklists. All process participants must process the activity one after the other.

As process participant, you can specify a Distribution List, an Organizational Unit or a Property of the Object from which a list of process participants can be determined. Distribution lists can only be used together with multi-instances. An organizational unit or property of the object can be used both in multi-instances and in non-multi-instances. In the case of multi-instances, a separate activity instance is created for each resolved process participant, in the case of non-multi-instances only one activity instance for the entire organizational unit or property of the object (single-valued) is created. Multi-valued properties of the object are only allowed for multi-instances.

Ad-Hoc Process

In ad-hoc processes, you can also choose between “No Multi-Instance”, “Parallel” and “Sequential”.

Notes

  • Distribution lists are immediately resolved at the start of the process. When a Property of the Object or Organizational Unit is used, the process participants are resolved during the runtime of the workflow (when the state of the corresponding activity is set to “Can Be Started”)
  • If the property of the object is single-valued and contains an organizational unit, all users directly assigned to the organizational unit receive an activity. Subordinated organizational units are not considered.
  • If the property of the object is multi-valued, all directly defined users receive an activity. In addition, all directly defined organizational units receive a joint activity.

Processes and FormsPermanent link for this heading

If a user-defined form is applied to a document, a two-part view is opened when you perform the “Open” step of activities like “Edit” or “Release”. This allows you to view the document and capture metadata directly.

If a BPMN process is restricted to the category of a user-defined base form, the process can also be used for forms derived from the base form.

Additional ImprovementsPermanent link for this heading

The workflow offers additionally the following new possibilities:

  • To make it easier to define signatures as a condition in BPMN processes, the properties Last Signature, Last Signature on/at, Last Signature by and Remark of Last Signature have been introduced.
  • The Applicable for property is now available directly in the BPMN editor. If the process is restricted to a category of a user-defined form or to an object class, the defined fields can be used in the condition editor.
  • In the BPMN process editor, an app.ducx expression can be defined for tasks in the Expression When Completing the Activity field. This expression is executed when completing the activity.
  • For the definition of an abstract participant of a process, a property of the object (e.g. Last Signature by) can be used. The participant is evaluated at runtime. This is particularly useful for automatically started processes because abstract participants such as process initiators do not make sense in that case.
  • The abstract participant “Property of the File of the Object” can be used to determine the participant based on the properties of the object's file.
  • A wait action can be implemented using an intermediate conditional event. The process is not continued until the condition (app.ducx expression) has been fulfilled. The check interval determines how often the condition is checked.
  • If the activities “Review”, “Approve” or “Release” are used in ad hoc processes, the following applies:
    • Negative results (e.g. “Approval denied”) are reported via an automatically inserted activity to the person who started the ad hoc process. The remaining commonly prescribed activities that have not yet been completed are set to “Not Executed”.
    • Activities for positive results (e.g. “Released”) are only automatically inserted if they are the last activity in the process.
  • If the activities “Review”, “Approve” or “Release” are inserted in running processes, negative results are reported to the person who inserted the activities. The remaining commonly inserted activities that have not yet been completed are set to “Not Executed”.
  • BPMN condition expressions are evaluated with NOCHECK. This avoids evaluation errors that properties are not assigned to the object class.
  • In the workflow settings, in the Show News About New Activities on the Welcome Screen field, you can define whether news about new activities in the worklist are shown on the welcome screen (if enabled in principle).
  • The activity “Review” is now additionally available.
  • The activity “Execute Expression in Background” is used for executing an app.ducx expression in the background. The process is not continued until the background task has been executed.
  • “Approve and Close” Activity
    The provided standard activities are extended by the “Approve and Close” activity. When the “Approve and Close” work step is performed, the object is signed with the “Approve” signature and the object is finalized, such that no further changes are possible.
  • The “Add Remark” activity is now available. This way remarks with attachments can be added to objects in the workflow.
  • You can define whether when finishing an activity in the worklist the next activity will be opened or whether the “to do” list will be opened (account menu > “Advanced Settings” > “Workflow” > Automatically Open the Next Activity After Finishing an Activity).

Improved UsabilityPermanent link for this heading

The following improvements make the daily work with Fabasoft Folio easier.

Working Efficiently With Long ListsPermanent link for this heading

The delay in the presentation of lists with many entries belongs to the past. When navigating in a list with more than 250 entries, not all entries will be loaded at once. When scrolling through the list, entries are loaded automatically when they are needed for the displayed area. Therefore the web browser can display the shown list area much faster, which brings advantages especially when using the detail view.

When navigating with the breadcrumb or the back functionality of the web browser, the recently opened section of the list is displayed. The keyboard navigation works also smoothly. Page up and Page down change the focus to the first or last visible entry. Home and End navigate to the first or last entry in the list. With Alt + F9 you can access the column header. Alt + A selects all entries as usual. The column filter also takes the entire list into account.

Although the Fabasoft Folio Web Client now optimally supports long lists, you should avoid confusing lists anyway.

Working With Lists in the Property EditorPermanent link for this heading

To reduce the complexity of the property editor and improve the overview, a simplified view is now available for object and aggregate lists. The “Show details” button takes you to a full view of the list optimized for editing.

Simplified List

The reduced editing options in the simplified list provide an improved overview.

  • No menu bar is displayed.
  • The number of entries displayed depends on the context. In general, a maximum of 15 entries are displayed. The “Further Entries” button takes you to the full view.
  • Sorting and grouping cannot be carried out in the simplified list. These are taken over by the settings in the full view.
  • Only as many columns as space is available are displayed. Thus, horizontal scroll bars can be avoided.
  • Thumbnails are not displayed in the detail view.
  • Actions on the entries can be carried out via the context menu.
  • Actions concerning the list can be offered via buttons above the list.
  • Direct editing with F2 is possible depending on the list.
  • If there are more entries that can be displayed on a page, the column headings are fixed.

Full List

The full list is used in particular for editing and can be accessed via the “Show Details” button of the simplified list. If the list is the only field on a tab, the full list can also be displayed directly.

  • The full view makes optimum use of the window width.
  • The full list offers the complete list functionality as usual.
  • If there are more entries that can be displayed on a page, the column headings are fixed.

Possible Uses of the Context MenuPermanent link for this heading

You may know that the context menu can be opened for any entry in a list. The context menu provides different actions based on the selected entries. It can be opened with the right mouse button or a keyboard user can use the menu key or the shortcut Shift + F10.

Less well known is

  • that there is also a context menu available in the window background, which can be used, for example, to change the view.
  • that the context menu of the currently displayed document or folder can be accessed by right-clicking the name in the title bar.
  • that you can open the context menu in the document view over a thumbnail, video or audio element.
  • that you can also use the context menu on mobile devices (smartphones and tablets) with a so-called “long touch” (touch the desired area about two seconds).

Follow-UpsPermanent link for this heading

You can use the follow-up functionality to specify that an e-mail is sent to a user or a process is started to remind of a task to be completed.

You can create follow-ups using the “Create Follow-Up” or “Manage Follow-Up” context menu command. In addition to the action to be performed, you must also define the date for the execution. The date can be an explicit date or a date calculated based on a base date field. In addition, you can specify whether the execution date is adjusted when the base date value changes.

When managing follow-ups, you can specify the period for which the follow-ups are to be displayed. As long as the status of the follow-up is “Created”, it can still be changed.

You can get an overview of all the follow-ups that concern you in the “Follow-Ups” widget, which is located directly on “Home”.

Convert Folder to TeamroomPermanent link for this heading

The access rights to Teamrooms and the contained objects are defined by the team specified in the Teamroom. Folders are used for structuring, but do not have their own rights context.

If you want to give a folder a different right context, you can now use the “Tools” > “Convert to Teamroom” context menu command to convert a folder (contained in a Teamroom) to a Teamroom. Conversely, you can also convert a Teamroom located in another Teamroom into a folder.

Note:

  • To convert a folder into a Teamroom, you need to have full control in the Teamroom associated with the folder.
  • To convert a Teamroom to a folder, you need full control in that Teamroom and change access in the target Teamroom for the folder.
    If the converted Teamroom is located in multiple Teamrooms, you can select the target Teamroom for the folder.

Publishing of TeamroomsPermanent link for this heading

When re-publishing Teamrooms, you now have the option to transfer only the changes since the last publishing. Especially Teamrooms that contain many objects with only a few changes are transferred much faster.

Time TravelPermanent link for this heading

The time travel is another way to view versions in the past. Via the “Time Travel” > “Start Time Travel” action you can start the time travel. Use the timeline to reach easily and quickly the desired point in time.

  • “Start Time Travel”, “Continue Time Travel”, “End Time Travel”
    Select the version you want to view or end the time travel. As an alternative to selecting a version, you can specify a point in time.
  • “Save Current Version”
    Saves a version of the current state. The version can also be treated as “release version”. This way, team members with read access can only see this version. A new release version replaces a possibly present release version.
  • “Clean up Versions”, “Delete”
    No longer required versions can be deleted.
  • “Compare”
    Compares the selected version with the current version. The contents of Word documents can be compared.
  • “Restore”
    The current version is replaced by the selected version.

Additional ImprovementsPermanent link for this heading

The following additional improvements are available:

  • When a date field is focused, a calendar is opened that allows efficient selection of the desired date.
  • By using standard lists for displaying the Mindbreeze search result, you can also use the usual functionality in hit lists. For example, you can change the view or display additional columns.
  • The document view can be switched to full screen mode, for example, to be able to use the entire screen for pictures.
  • The table of contents in the PDF view of a Teamroom is displayed up to the twentieth level.
  • In the Teamrooms properties, on the “Content Settings” tab, you can specify whether a cover sheet should be generated for PDF views of documents assigned to the Teamroom. You can select which versions or signatures are to be displayed on the cover sheet.
  • Folders now also provide the “Tools” > “Add to Teamroom Templates” context menu command.
  • Objects copied to the clipboard are also taken into account in the “History”.
  • If you select multiple objects and execute the “Rename” context menu command, a rename dialog is opened for each selected object. When you click “Cancel”, all changes are discarded.
  • The layout of the PDF overviews has been completely revised and now corresponds to the web client property dialog. In the Fabasoft Folio Apps, the PDF overviews are optimized for the form factor of mobile devices. Of course, the accessibility of PDF documents was taken into account.
  • The highlight color of objects is now displayed in all list views. You can set the highlight color using the context menu. If you are dependent on assistive technologies, you can get a textual label by choosing “Basic Settings” > “Accessibility” tab > Show Alternative Text for Highlighted Fields. In the detail view, you can add the “Highlighting Color” column.
  • In order to support keyboard users, the focus frame is activated as soon as any navigation button is pressed.
  • If you are in the worklist and navigate to the affected objects, the workflow context is preserved even if you use the back button of the web browser.
  • Remarks can now also be added to objects via the context menu command “Tools” > “Remarks”.
  • In the detail view up to 50 columns can be added (instead of 25).
  • When you execute the “Clipboard” > “Data Table” > “Copy” menu command and some lines are selected only those lines will be copied to the clipboard. The order in which the lines were selected is taken into account.
  • The new object class „CAD Drawing“ is provided for following file types: dwg, dwf, dxf, CATDrawing, CATPart, CATProduct.
  • The object class “Content (Unknown Type)” has been renamed to “Content”.
  • To ensure optimal column widths in lists, they are by default dynamically determined based on the length of the values ​​in the columns. If you specify the column widths manually or presets exist, no dynamic width adjustment takes place. However, you can optimize the width of the respective column in the column header by double-clicking the area between two columns.
  • When entering a search query, suggestions are displayed.
  • Orientation of Pictures
    If the EXIF information for the orientation is available in pictures, it is taken into account when displaying the thumbnails. The picture itself is not changed.
  • XPS or OXPS files (XML Paper Specification) are supported and can be opened in the Microsoft XPS Viewer.
  • According to the Web Content Accessibility Guidelines (WCAG), the diagrams have been revised to better support users with visual impairments.
  • If you edit a field in a list with F2, the change is saved by a click outside the edit field. If you click on a clickable element, the corresponding action is also executed.
  • Editing columns in the detail view
    You can edit fields displayed in the detail view directly with F2, without having to open the properties of the respective objects. You can now also edit multi-value fields (lists, aggregates) in addition to single-valued fields. In this case an overlay for entering the data is opened.

Third-Party IntegrationPermanent link for this heading

The third-party integration provides following new features.

Annotating PDF DocumentsPermanent link for this heading

Annotations that you attach to a PDF document using an external PDF viewer can be separated from the PDF document and saved on a public or personal layer. Thus, the document does not have to be duplicated if you want to share general comments with other team members but personal comments should only be visible to you.

To create public annotations, edit the PDF document as usual (e.g. “Edit” action). In the external PDF viewer, you can attach the corresponding annotations and save the document again.

To create personal annotations, navigate in the PDF document. In the PDF preview, use the “Show comments toolbar” and “Comment” buttons to open the PDF document for editing. The annotations attached in the external PDF viewer are saved as personal annotations.

Notice:

  • If the PDF content itself changes (e.g. by replacing it with another file), the previous documents including annotations are still available. The documents can be selected via a drop-down field in the PDF preview.
  • If the PDF document already contains annotations during import, these are saved in a public layer when you enable the comment bar and are therefore visible to all team members.
  • When you download a PDF document, the PDF content is annotated with the annotations visible to you.
  • You can specify whether annotations can be added to PDF documents of a Teamroom on the “Content Settings” tab in the Allow Comments field. Annotations are always allowed for PDF documents that are not assigned to Teamrooms.

Microsoft Office IntegrationPermanent link for this heading

The integration in Microsoft Office allows you to perform actions directly from the application.

The domain and account selection can be made directly in the Office product. Thus, for example, you can easily use several installations at the same time.

Microsoft Outlook IntegrationPermanent link for this heading

The integration in Microsoft Outlook gives you the following options.

  • In Microsoft Outlook, on the “Start” tab, in the “Fabasoft Folio” group, you can use the “Upload E-Mail” button to import the selected e-mails in a Teamroom or folder. When choosing the folder using the “Choose Folder” button, you can also create a new Teamroom or folder.
    Alternatively, you can also copy e-mails as usual (Ctrl + C) and paste them into Fabasoft Folio (Ctrl + V).
  • When composing an e-mail, the “Check Access” button is available in the “Fabasoft Folio” group. This enables you to check whether the recipients have access to the Folio objects linked in the e-mail. You can perform the check manually using the “Check Now” button. Enable the “Always Check on Send” option to perform the check automatically.
  • The generation of PDF overviews and the extraction of metadata from e-mails can now take place independently of the client directly in Fabasoft Folio.  For example, you can store an email in a Folio network drive and the metadata is still extracted.
  • In Fabasoft Folio, the importance of e-mails (high or low) is displayed as status symbol.

Contact Synchronization With Microsoft OutlookPermanent link for this heading

You can synchronize contacts that you manage in Fabasoft Folio with Microsoft Outlook. The “Open Folio Address Book” command is available in the context menu of the Fabasoft Folio notification symbol (if configured in the user environment). Your address book list is added in Microsoft Outlook under “Contacts” and automatically kept synchronized. With the “Synchronize” context menu command of the Fabasoft Folio notification symbol, you can also perform the synchronization manually.

Note:

  • You can find your address book list under “Account menu (your user name)” > “Advanced Settings” > “Address Book”. Here you can manage your contacts and create additional address books.
  • Contacts can be synchronized from Fabasoft Folio to Microsoft Outlook but not vice versa. The contacts are available in Microsoft Outlook as read-only contacts.

Integration in Microsoft WordPermanent link for this heading

The integration in Microsoft Word gives you the following options.

Buttons

You can perform actions in Fabasoft Folio directly from Microsoft Word. The “Fabasoft Folio” tab In Microsoft Word offers the corresponding actions depending on the context.

  • Open
    You can select the document in Fabasoft Folio and open it in Microsoft Word.
  • Upload
    If the current document was not opened via Fabasoft Folio, it can be uploaded to Fabasoft Folio. You can select a location in Fabasoft Folio and continue processing directly without having to close the document.

Note: In Microsoft PowerPoint and Microsoft Excel, the “Open” and “Upload” buttons are available on the Fabasoft Folio tab, too.

Forms and Fields

When you add a user-defined form to a Word document, you can insert your defined properties as updatable and modifiable fields (depending on the property type) in the Word document. In Microsoft Word, on the “Fabasoft Folio” tab, the “Insert Field” button is available for this purpose.

The following property types can be edited in the Word document:

  • Integer
  • String (also multi-line)
  • Date
  • Date and time
  • Boolean
  • Enumeration

The other property types are displayed as read-only fields.

Note:

  • When saving the content, the fields in the PDF view are updated automatically, regardless of whether the PDF view is generated on the server or on the client.
  • On the “Content” tab, in the Update PDF Content on Metadata Change field you can define whether the PDF view is newly generated on the server when the metadata of the object gets changed. This way, fields that refer to the metadata of the document are displayed with current values.
  • The properties Last Signature, Last Signature by, Last Signature on/at and Remark of Last Signature can be inserted in Word documents as fields.
  • When you create a user-defined form and choose “Container With User Data” or “Room With User Data” as base class, you can also specify whether it is a file. The reference to the file is saved for the subordinate objects. This makes it possible, for example, that the properties of the file are also available as fields in Microsoft Word.

PDF View

You have the option that the PDF view of Microsoft Office documents is generated locally. This has the advantage that the mapping between the document and the PDF document is much better, when only LibreOffice instead of Microsoft Office is available on the conversion server.

Whether you want to generate the PDF view on the workstation or on the conversion server can be defined in the options of the Fabasoft Folio Client. To do so, open the context menu of the Fabasoft Folio Client notification symbol and click “Options”. On the “Content” tab, you can set the following:

Documents

  • Generate PDF Preview on the Workstation
    • Microsoft Word
    • Microsoft Excel
    • Microsoft PowerPoint
    • Microsoft Visio

Fabasoft Folio ClientPermanent link for this heading

The Fabasoft Folio Client offers following new possibilities.

User InterfacePermanent link for this heading

By clicking on the notification icon of the Fabasoft Folio Client the list of recently used documents is opened.

  • Header
    If you work with multiple installations, you can switch between them via the header. By clicking on the question mark, the support dialog is opened. Via the gear icon you can access the options.
  • Footer
    In the footer, you can initially start synchronizing or the current state of the synchronization is shown. By clicking on the synchronization state, you can pause the synchronization.
  • Document overview
    The open, recently edited, renamed, downloaded or uploaded documents are displayed chronologically. If an error occurs when synchronizing, the affected file is shown with a red background.
    Via the context menu of the respective document you can
    • view the document in the Windows Explorer (if it is synchronized),
    • view the document in the Fabasoft Folio Web Client or
    • copy a link to the document into the clipboard.

Fabasoft Folio Client on UbuntuPermanent link for this heading

The Fabasoft Folio Client is now also available on Ubuntu. Like on other operating systems you can now conveniently make settings via the notification symbol and display the recently used documents.

Keyboard OperationPermanent link for this heading

The Fabasoft Folio Client can be fully operated using the keyboard. To get in the document overview of recently used documents, focus the notification icon and press the spacebar. Tab and arrow keys are used for navigation. The context menu for the individual entries can be opened via the menu key.

SynchronizationPermanent link for this heading

The synchronization of documents with the local file system provides following new possibilities:

  • The bandwidth used for synchronizing can be restricted in the options dialog of the Fabasoft Folio Client.
  • If a folder contains unsynchronized documents and you execute the “Folio Folder” > “Remove Local Files” context menu command, an error will be displayed. When you execute the context menu command again, the unsynchronized documents are removed and a backup is stored in \Users\<user>\Documents\My Recovered Documents.
  • If you want to cancel the download of a too large file, you can execute the “Folio Folder” > “Remove Local Files” context menu command on the parent folder.
  • On Apple macOS, it is possible to tag files. When using the Fabasoft Folio Folder, these tags are now synchronized as well.
  • When synchronizing documents and folders, shortcuts are considered. Each document shortcut is synchronized as complete file and changes are carried out at all locations. Additionally, the status display of the Fabasoft Folio Client has been extended.

Note: If you are still using the old synchronization, the Folio Folder must be recreated. When synchronizing the first time with the current version a corresponding note is displayed. The upgrade process deletes the existing Folio Folder along with all contents. Therefore, back up any unsynchronized files before confirming the upgrade.

LAN SynchronizationPermanent link for this heading

By default, synchronization is carried out with Fabasoft Folio. Alternatively, you can also enable LAN synchronization.

When data in Fabasoft Folio has changed, all Folio Folders in the local network are contacted first, whether the changed data is already available locally. If this is the case, the data is synchronized over the LAN and not over the Folio installation. Security is ensured in both cases by encryption.

To be able to use the LAN synchronization, you have to enable it:

  1. Open the context menu of the Fabasoft Folio notification icon and click "Options".
  2. On the “Bandwidth” tab, enable the LAN Synchronization.
    • LAN synchronization should only be used in trusted networks.
    • Under Microsoft Windows ensure that the network type is either “Domain Network” or “Private Network” (Network and Sharing Center). Otherwise you cannot enable the LAN synchronization.
    • Under macOS you can activate the LAN synchronization for the current network.

Note:

  • The clients must be connected to both, the LAN (same subnetwork) and Fabasoft Folio.
  • The communication uses the TCP port 17096 and the IP multicast address 224.0.0.202 or ff02::1 (local subnetwork). If necessary, appropriate settings must be made in the firewall. If you are encountering problems with LAN synchronization, please contact your network administrator with this information.

Administration of the Fabasoft Folio ClientPermanent link for this heading

As a Windows administrator, you can centrally define the Fabasoft Folio Client options for your users. For this purpose, a corresponding registry value can be defined for each setting in the options dialog.

Further information can be found in the white paper “Fabasoft Folio Client”.

Additional ImprovementsPermanent link for this heading

The Fabasoft Folio Client offers additionally the following new possibilities:

  • E-mails can be stored directly from IBM Notes via drag-and-drop in Fabasoft Folio. Alternatively, the “Actions” > “Upload E-Mail (Fabasoft Folio)” menu command can be used.
  • The Fabasoft Folio Client for Apple macOS additionally offers the “Open Folio Calendar” context menu command. The command makes it very easy to connect to the Folio calendar without manual configuration effort.
  • Archives in 7z format can be opened directly from Fabasoft Folio with the third-party product 7-Zip. The table of contents of the archive is available as a preview analogous to the ZIP format.
  • Documents can be copied and pasted directly from a Folio or Private Cloud installation into Fabasoft Folio.

Common ImprovementsPermanent link for this heading

  • The account menu (your user name) has been restructured. In the “Advanced Settings” and “State” submenus, you will find the less frequently used commands.
  • Under “account menu (your user name)” > “Advanced Settings” > “Notifications”, you can define about which events you want to be informed. You can be informed either by e-mail or by events displayed in the Teamroom (“Show New Events” action).
    On the “Notifications” or “Disabled Notifications” tab, define for which Teamrooms or dashboards you want to receive events. For the objects entered, the setting applies to the entire hierarchy unless another setting has been made for a subordinate object.
  • When using screen readers, you can specify that well-known English terms are specially tagged to ensure correct pronunciation (“account menu (your user name)” > “Basic Settings” > “Accessibility” tab > “Prepare Foreign Language Expressions for Speech Output”).
  • The background context menu also contains the “Search” command.
  • Objects that are assigned to other Teamrooms can also be used as Teamroom templates. Make sure that the team members are authorized in the other Teamrooms to be able to use the templates.
  • In the properties of a Teamroom, in the Restrict the Downloading or Opening of Content on the Workstation field you can restrict the team members who are offered the actions for editing and downloading in the web browser client.
  • Search folders can be used to search for Wastebasket (Teamroom) in order to be able to empty also a large number of wastebaskets efficiently.
  • For search folders, the actions “Create Search Form”, “Edit Search Form” and “Properties” are also available. This allows you to easily configure search folders.
  • If you define a user-defined form as a file, you automatically have access to file-typical actions such as “Replace”, “Close”, “Cancel” and “Restore”.
  • A base form can be defined for user-defined forms. This way the form pages and fields of the base form are taken over. In addition, expressions can be defined for fields: compute visibility of field, compute value of field, compute changeability of field, handle changes of field and validate value.
  • When creating user-defined forms, you can drag and drop fields from one tab to another. Alternatively, you can use the context menu command “Move”.
  • The properties displayed on the “General” tab of objects have been reworked and consolidated.
  • As an alternative to selecting a version, you can specify a point in time in the time travel.
  • When downloading a folder, the generated ZIP file now contains the contents of the folder at top level and not the folder itself. This helps to reduce problems with long path names.
  • If standard background tasks of a category are already to be executed when the category is assigned, they are executed immediately and not delayed by an automatic task.
  • In the case of standard background tasks, you can use the Recalculate the Date When the Base Date Changes field to determine whether the execution time of the background task should be modified when the base date is changed. Background tasks that have not yet been executed are executed at the newly calculated time and background tasks that have already been executed are executed again.
  • When defining follow-ups, background tasks or retention periods, you can also select date properties of user-defined forms. The properties offered are filtered according to the context. You can also specify whether the period is subtracted from the base date or added to it (e.g. 3 days before “Valid to”, 2 years after “Created on/at”).
  • Downloading large files starts much faster because the consistency of the files is checked during the download and not before the start.
  • Any objects as favorites
    You can add any objects (for example, individual documents) to your favorites.
  • The W3C recommendation “SOAP Message Transmission Optimization Mechanism” (https://www.w3.org/TR/soap12-mtom/) is supported.
  • When importing e-mails (EML or MSG), attachments can now be extracted on the server side. Neither Microsoft Outlook nor the Fabasoft Folio Client is required on the client for this functionality.

AdministrationPermanent link for this heading

  • Domain Workflow Preferences can now also be defined for a tenant. The evaluation chain is now: user environment, user, group, tenant and workflow configuration.
  • In the workflow configuration, on the “Activities” tab the Delete Activities from the Worklist field is provided. In this field, you can define who is allowed to delete activities (with state “Waiting for Submission”, “Startable”, “Started”, “Waiting for External Synchronization” and “Suspended”) in running processes.
  • The Fabasoft Folio RPM packages are signed using a GPG key (https://www.gnupg.org). This signature can be verified to ensure that the packages have not been compromised.
    For more information see the white paper “Fabasoft on Linux - Installation of Fabasoft Folio Services”.
  • In der vApp-Konfiguration kann auf der Registerkarte „Web-Service-Sicherheit“ im Feld X-XSS-Protection Header der gewünschte Wert („0“, „1“, „1; mode=block“ oder „1; report=<reporting-URI>“) festgelegt werden.
  • A script with the comment LANGUAGE="JavaScript" in the first line now uses the ADE-KJS JavaScript engine on Microsoft Windows and Linux. In earlier versions, the Windows JavaScript engine was used in this case on Microsoft Windows. To achieve the old behavior, the comment LANGUAGE="JScript" can be used.

DiscontinuationPermanent link for this heading

Following functionality is no longer available:

  • Keyboard shortcuts for menus are no longer available.
  • The user interface has been replaced by a new one. Software components and objects related to the old user interface have been removed (e.g. FSCVAPP@1.1001:XML, FSCVAPP@1.1001:ColorScheme, FSCFOLIOTHEMES@1.1001).
  • The CMSPortlet and the software components Integration for Blogs (FSCBLOGS@1.1001), Integration for Message Boards (FSCMBOARD@1.1001), Integration for Wikis (FSCWIKI@1.1001) and Integration for Liferay Portal (FSCLIFERAY@1.1001) are no longer available.

Following third-party products are no longer supported:

  • Kofax Capture 10.0.2 is no longer supported.
  • Microsoft Windows Server 2012 R2 is no longer supported.
  • Microsoft SQL Server 2014 SP2 is no longer supported.
  • Microsoft Office 2010 SP2 is no longer supported.
  • Microsoft Visio 2010 SP2 is no longer supported.
  • Microsoft Project 2010 SP2 is no longer supported.
  • Microsoft Windows 7 SP1 is no longer supported.
  • Microsoft Windows 8.1 is no longer supported.
  • Microsoft Office for Mac 2016 is no longer supported.
  • Oracle Java is no longer supported.