Improved UsabilityPermanent link for this heading

The following improvements make the daily work with Fabasoft Folio easier.

Working Efficiently With Long ListsPermanent link for this heading

The delay in the presentation of lists with many entries belongs to the past. When navigating in a list with more than 250 entries, not all entries will be loaded at once. When scrolling through the list, entries are loaded automatically when they are needed for the displayed area. Therefore the web browser can display the shown list area much faster, which brings advantages especially when using the detail view.

When navigating with the breadcrumb or the back functionality of the web browser, the recently opened section of the list is displayed. The keyboard navigation works also smoothly. Page up and Page down change the focus to the first or last visible entry. Home and End navigate to the first or last entry in the list. With Alt + F9 you can access the column header. Alt + A selects all entries as usual. The column filter also takes the entire list into account.

Although the Fabasoft Folio Web Client now optimally supports long lists, you should avoid confusing lists anyway.

Working With Lists in the Property EditorPermanent link for this heading

To reduce the complexity of the property editor and improve the overview, a simplified view is now available for object and aggregate lists. The “Show details” button takes you to a full view of the list optimized for editing.

Simplified List

The reduced editing options in the simplified list provide an improved overview.

  • No menu bar is displayed.
  • The number of entries displayed depends on the context. In general, a maximum of 15 entries are displayed. The “Further Entries” button takes you to the full view.
  • Sorting and grouping cannot be carried out in the simplified list. These are taken over by the settings in the full view.
  • Only as many columns as space is available are displayed. Thus, horizontal scroll bars can be avoided.
  • Thumbnails are not displayed in the detail view.
  • Actions on the entries can be carried out via the context menu.
  • Actions concerning the list can be offered via buttons above the list.
  • Direct editing with F2 is possible depending on the list.
  • If there are more entries that can be displayed on a page, the column headings are fixed.

Full List

The full list is used in particular for editing and can be accessed via the “Show Details” button of the simplified list. If the list is the only field on a tab, the full list can also be displayed directly.

  • The full view makes optimum use of the window width.
  • The full list offers the complete list functionality as usual.
  • If there are more entries that can be displayed on a page, the column headings are fixed.

Possible Uses of the Context MenuPermanent link for this heading

You may know that the context menu can be opened for any entry in a list. The context menu provides different actions based on the selected entries. It can be opened with the right mouse button or a keyboard user can use the menu key or the shortcut Shift + F10.

Less well known is

  • that there is also a context menu available in the window background, which can be used, for example, to change the view.
  • that the context menu of the currently displayed document or folder can be accessed by right-clicking the name in the title bar.
  • that you can open the context menu in the document view over a thumbnail, video or audio element.
  • that you can also use the context menu on mobile devices (smartphones and tablets) with a so-called “long touch” (touch the desired area about two seconds).

Follow-UpsPermanent link for this heading

You can use the follow-up functionality to specify that an e-mail is sent to a user or a process is started to remind of a task to be completed.

You can create follow-ups using the “Create Follow-Up” or “Manage Follow-Up” context menu command. In addition to the action to be performed, you must also define the date for the execution. The date can be an explicit date or a date calculated based on a base date field. In addition, you can specify whether the execution date is adjusted when the base date value changes.

When managing follow-ups, you can specify the period for which the follow-ups are to be displayed. As long as the status of the follow-up is “Created”, it can still be changed.

You can get an overview of all the follow-ups that concern you in the “Follow-Ups” widget, which is located directly on “Home”.

Convert Folder to TeamroomPermanent link for this heading

The access rights to Teamrooms and the contained objects are defined by the team specified in the Teamroom. Folders are used for structuring, but do not have their own rights context.

If you want to give a folder a different right context, you can now use the “Tools” > “Convert to Teamroom” context menu command to convert a folder (contained in a Teamroom) to a Teamroom. Conversely, you can also convert a Teamroom located in another Teamroom into a folder.

Note:

  • To convert a folder into a Teamroom, you need to have full control in the Teamroom associated with the folder.
  • To convert a Teamroom to a folder, you need full control in that Teamroom and change access in the target Teamroom for the folder.
    If the converted Teamroom is located in multiple Teamrooms, you can select the target Teamroom for the folder.

Publishing of TeamroomsPermanent link for this heading

When re-publishing Teamrooms, you now have the option to transfer only the changes since the last publishing. Especially Teamrooms that contain many objects with only a few changes are transferred much faster.

Time TravelPermanent link for this heading

The time travel is another way to view versions in the past. Via the “Time Travel” > “Start Time Travel” action you can start the time travel. Use the timeline to reach easily and quickly the desired point in time.

  • “Start Time Travel”, “Continue Time Travel”, “End Time Travel”
    Select the version you want to view or end the time travel. As an alternative to selecting a version, you can specify a point in time.
  • “Save Current Version”
    Saves a version of the current state. The version can also be treated as “release version”. This way, team members with read access can only see this version. A new release version replaces a possibly present release version.
  • “Clean up Versions”, “Delete”
    No longer required versions can be deleted.
  • “Compare”
    Compares the selected version with the current version. The contents of Word documents can be compared.
  • “Restore”
    The current version is replaced by the selected version.

Additional ImprovementsPermanent link for this heading

The following additional improvements are available:

  • When a date field is focused, a calendar is opened that allows efficient selection of the desired date.
  • By using standard lists for displaying the Mindbreeze search result, you can also use the usual functionality in hit lists. For example, you can change the view or display additional columns.
  • The document view can be switched to full screen mode, for example, to be able to use the entire screen for pictures.
  • The table of contents in the PDF view of a Teamroom is displayed up to the twentieth level.
  • In the Teamrooms properties, on the “Content Settings” tab, you can specify whether a cover sheet should be generated for PDF views of documents assigned to the Teamroom. You can select which versions or signatures are to be displayed on the cover sheet.
  • Folders now also provide the “Tools” > “Add to Teamroom Templates” context menu command.
  • Objects copied to the clipboard are also taken into account in the “History”.
  • If you select multiple objects and execute the “Rename” context menu command, a rename dialog is opened for each selected object. When you click “Cancel”, all changes are discarded.
  • The layout of the PDF overviews has been completely revised and now corresponds to the web client property dialog. In the Fabasoft Folio Apps, the PDF overviews are optimized for the form factor of mobile devices. Of course, the accessibility of PDF documents was taken into account.
  • The highlight color of objects is now displayed in all list views. You can set the highlight color using the context menu. If you are dependent on assistive technologies, you can get a textual label by choosing “Basic Settings” > “Accessibility” tab > Show Alternative Text for Highlighted Fields. In the detail view, you can add the “Highlighting Color” column.
  • In order to support keyboard users, the focus frame is activated as soon as any navigation button is pressed.
  • If you are in the worklist and navigate to the affected objects, the workflow context is preserved even if you use the back button of the web browser.
  • Remarks can now also be added to objects via the context menu command “Tools” > “Remarks”.
  • In the detail view up to 50 columns can be added (instead of 25).
  • When you execute the “Clipboard” > “Data Table” > “Copy” menu command and some lines are selected only those lines will be copied to the clipboard. The order in which the lines were selected is taken into account.
  • The new object class „CAD Drawing“ is provided for following file types: dwg, dwf, dxf, CATDrawing, CATPart, CATProduct.
  • The object class “Content (Unknown Type)” has been renamed to “Content”.
  • To ensure optimal column widths in lists, they are by default dynamically determined based on the length of the values ​​in the columns. If you specify the column widths manually or presets exist, no dynamic width adjustment takes place. However, you can optimize the width of the respective column in the column header by double-clicking the area between two columns.
  • When entering a search query, suggestions are displayed.
  • Orientation of Pictures
    If the EXIF information for the orientation is available in pictures, it is taken into account when displaying the thumbnails. The picture itself is not changed.
  • XPS or OXPS files (XML Paper Specification) are supported and can be opened in the Microsoft XPS Viewer.
  • According to the Web Content Accessibility Guidelines (WCAG), the diagrams have been revised to better support users with visual impairments.
  • If you edit a field in a list with F2, the change is saved by a click outside the edit field. If you click on a clickable element, the corresponding action is also executed.
  • Editing columns in the detail view
    You can edit fields displayed in the detail view directly with F2, without having to open the properties of the respective objects. You can now also edit multi-value fields (lists, aggregates) in addition to single-valued fields. In this case an overlay for entering the data is opened.