2019 Update Rollup 1

Fabasoft Folio 2019Permanenter Link zu dieser Überschrift

Erfahren Sie mehr über Neuerungen und Verbesserungen von Fabasoft Folio 2019. Wenn nicht anders angegeben sind die Neuerungen und Verbesserungen in folgenden Editions verfügbar:

  • Fabasoft Folio Enterprise
  • Fabasoft Folio Compliance
  • Fabasoft Folio Governance

Die neue BenutzeroberflächePermanenter Link zu dieser Überschrift

Mit Fabasoft Folio 2019 erhalten Sie die neue Benutzeroberfläche. Hier finden Sie Tipps zum Umstieg, damit Sie sich unmittelbar zurechtfinden.

Bereiche des Fabasoft Folio Webclients

Der Fabasoft Folio Webclient bietet Ihnen eine intuitive, einfach zu erlernende und individuell anpassbare Benutzeroberfläche, die eine effiziente Bearbeitung Ihrer täglichen Aufgaben ermöglicht.

Der Webclient gliedert sich in folgende Bereiche:

  • Home (Startseite)
  • Kopfleiste
  • Werkzeugbereich
  • Titelleiste
  • Menüleiste (standardmäßig ausgeblendet)
  • Inhaltsbereich

Der neue Home-Bereich

Der neu gestaltete Home-Bereich bietet Ihnen einen besseren Überblick und vielfältige Anpassungsmöglichkeiten.

Das Dashboard-Konzept des Home-Bereichs ermöglicht Ihnen Widgets ein- bzw. auszublenden, deren Größe zu verändern und diese zu verschieben.

  • Persönliche Ablage
    In Ihrer persönlichen Ablage, können Sie die für Sie wichtigen Dokumente, Ordner und Teamrooms ablegen.
  • Mit mir geteilte Teamrooms
    Enthält alle Teamrooms, bei denen Sie als Teammitglied berechtigt sind. Ausgenommen davon sind Teamrooms, die Sie selbst erzeugt haben. Die Liste wird zur besseren Übersicht nach Jahren und Monaten strukturiert. Über die Aktion „In meiner Ablage einordnen“ können Sie die gewünschten Teamrooms zum Beispiel in Ihrer persönlichen Ablage, in den Favoriten oder direkt auf Home ablegen.
  • Favoriten
    Die Favoriten ermöglichen den schnellen Zugriff auf immer wieder benötigte Objekte.
  • Arbeitsvorrat
    Zeigt Ihren Arbeitsvorrat.
  • Verlauf
    Enthält die zuletzt verwendeten Objekte und zuletzt versendeten E-Mails.
  • Wiedervorlagen
    Enthält Ihre Wiedervorlagen, die in den von Ihnen definierten Zeitraum fallen.
  • Weitere Dashboards
    Apps, die eigene Dashboards anbieten, werden ebenfalls direkt auf Home angezeigt.

Home-Bereich individuell anpassen

Für die individuelle Anpassung Ihres Home-Bereichs stehen Ihnen folgende Möglichkeiten zur Verfügung:

  • Widgets ein- bzw. ausblenden
    Über das Menü „Ansicht“ können Sie Widgets ein- bzw. ausblenden.
  • Widgets verschieben bzw. die Größe ändern
    Sie können Widgets per Drag-and-drop oder über das Kontextmenü verschieben. Im Kontextmenü des Widgets können Sie zusätzlich die Größe festlegen.
  • Objekte auf Home ablegen
    Zusätzlich zu den Widgets können Sie auch wichtige Objekte zum Beispiel mittels Kopieren und Einfügen direkt auf Home ablegen.
  • In den Grundeinstellungen unter Bedienungshilfen können Sie im Feld Hintergrundbilder in Dashboards und Home anzeigen festlegen, ob Hintergrundbilder angezeigt werden sollen.

Schnellzugriff

Über die Schaltfläche „Schnellzugriff“ ganz rechts in der Kopfleiste können Sie die Home-Dashboard-Ansicht öffnen und durch einen Klick auf das jeweilige Element in dieses navigieren.

Tastenkombinationen

Die Elemente auf Home können abhängig vom Webbrowser mit folgenden Tastenkombinationen direkt ausgewählt werden. Bei mehreren Elementen mit gleichem Anfangsbuchstaben ist das Verhalten vom Webbrowser abhängig (Navigation in ein Element bzw. Selektion eines Elements).

Microsoft Windows

  • Microsoft Internet Explorer: Alt + Anfangsbuchstabe
  • Google Chrome; Alt + Anfangsbuchstabe
  • Mozilla Firefox: Alt + Umschalttaste + Anfangsbuchstabe

Apple macOS

  • Apple Safari: Strg + Alt + Anfangsbuchstabe
  • Google Chrome: Strg + Alt + Anfangsbuchstabe
  • Mozilla Firefox: Strg + Alt + Anfangsbuchstabe

Linux

  • Mozilla Firefox: Alt + Umschalttaste + Anfangsbuchstabe
  • Kopfleiste
  • In der Kopfleiste finden Sie links Ihr Logo und rechts das Kontomenü (Ihr Benutzername), die Support-Schaltfläche, die Abmelden-Schaltfläche, die Schnellzugriff-Schaltfläche und das Suchfeld.
  • Hinweis: Die angezeigten Schaltflächen sind abhängig von der Konfiguration Ihrer Folio-Installation.

Kopfleiste

In der Kopfleiste finden Sie links Ihr Logo und rechts das Kontomenü (Ihr Benutzername), die Rollen-Schaltfläche, die Support-Schaltfläche, die Abmelden-Schaltfläche, die Schnellzugriff-Schaltfläche, die Home-Schaltfläche und das Suchfeld.

Hinweis: Die angezeigten Schaltflächen sind abhängig von der Konfiguration Ihrer Folio-Installation.

Werkzeugbereich

Der Werkzeugbereich steht in allen Widgets zur Verfügung, jedoch nicht direkt auf „Home“.

Die kontextunabhängigen Werkzeuge „Baumansicht“ und „Favoriten“ sind über eine Schnellauswahl auf- bzw. zuklappbar. Die „Aktionen“ (z. B. „Hochladen“) stehen Ihnen immer zur Verfügung. Je nach Kontext werden Ihnen unterschiedliche Aktionen angeboten.

Es können bis zu drei Werkzeugbereiche nebeneinander dargestellt werden (z. B. „Baumansicht“, „Aktionen“ und „Team“). Die Baumansicht kann vergrößert werden, um auch längere Einträge bequem lesen zu können.

Baumansicht

In der Baumansicht werden Objekte, die eine Objektlisteneigenschaft besitzen, hierarchisch angezeigt. Dies sind zum Beispiel Ordner, die weitere Ordner oder Dokumente enthalten können. Durch einen Klick auf ein Objekt in der Baumansicht wird die Objektliste des entsprechenden Objekts im Inhaltsbereich angezeigt.

Favoriten

Sie können häufig verwendete Objekte (z. B. Teamrooms oder Dokumente) zu Ihren Favoriten hinzufügen. Navigieren Sie dazu in das gewünschte Objekt. Dieses wird im Favoriten-Werkzeug zum Hinzufügen angeboten.

Aktionen

Im Werkzeugbereich „Aktionen“ finden Sie wichtige Aktionen, die im aktuellen Kontext gültig sind.

Titelleiste

In der Titelleiste finden Sie die Breadcrumbs der aktuell geöffneten Hierarchie. Durch einen Klick auf einen Breadcrumb gelangen Sie zu dem entsprechenden Objekt. Durch einen Rechtsklick können Sie das Kontextmenü des Objekts öffnen.

Befinden Sie sich in einem Widget, werden weitere Widgets auf der gleichen Ebene als Registerkarten angezeigt.

Menüleiste

Über die Menüleiste (standardmäßig ausgeblendet) werden Ihnen Menübefehle angeboten. Menübefehle können entweder kontextunabhängig sein (z. B. „Benutzereinstellungen“), sich auf das im Inhaltsbereich angezeigte Objekt beziehen (z. B.  „Neu“) oder auf die im Inhaltsbereich selektierten Objekte (z. B. „Umbenennen“).

Um die Menüleiste einzublenden, gehen Sie folgendermaßen vor:

  1. Klicken Sie auf das Kontomenü (Ihr Benutzername) und dann auf „Grundeinstellungen“.
  2. Markieren Sie die Option Menüleiste anzeigen.
  3. Klicken Sie auf „Speichern“.

Inhaltsbereich

Im Inhaltsbereich wird der Inhalt des aktuellen Objekts angezeigt. Dies kann zum Beispiel der Inhalt eines Ordners oder die Vorschau eines Dokuments sein. Die oberste Ebene wird als „Home“ bezeichnet.

Doppelklick

Bisher wurden Objekte durch einen Doppelklick geöffnet und durch einen einfachen Klick markiert. In der neuen Benutzeroberfläche gibt es – wie in Weboberflächen üblich – keinen Doppelklick mehr. Ein einfacher Klick öffnet das Objekt, die Markierung erfolgt über ein Auswahlkästchen.

Um ein Dokument in einem Drittprodukt zu öffnen, können Sie durch einen Klick auf das Dokument in die Inhaltsansicht wechseln und anschließend im Werkzeugbereich die Aktion „Bearbeiten“ bzw. „Lesen“ ausführen. Alternativ können Sie auch über das Kontextmenü (Rechtsklick) die Befehle ausführen.

Zum Umbenennen markieren Sie einen Eintrag und drücken Sie „F2“ oder Sie führen den Kontextmenübefehl „Umbenennen“ aus.

Bildergalerie

Werfen Sie einen Blick in die Bildergalerie, um einen Eindruck vom neuen Design zu erhalten.

Bild 1: Ansicht eines Ordners

Bild 2: Geöffnete Baumansicht

Bild 3: Mobiles Endgerät

FormularePermanenter Link zu dieser Überschrift

Die Ihnen zur Verfügung stehenden Möglichkeiten beim Erstellen von benutzerdefinierten Formularen wurden massiv erweitert.

Formulareditor

Im grafischen Formulareditor können Sie mittels Drag-and-drop neue Formulare entwerfen und somit auch ohne Programmierkenntnisse Objekte um eigene Eigenschaften erweitern.

Der Formulareditor wurde vollständig überarbeitet und fügt sich nun nahtlose in die gewohnte Benutzeroberfläche ein. Zusätzlich ist die Accessibility gewährleistet und somit von blinden Benutzern problemlos bedienbar.

Formularfelder

Folgende Formularfelder können Sie auf Ihrem Formular verwenden:

  • Eingabefeld
    Ein einwertiges Feld eines bestimmten Typs (z. B. Zeichenkette, Datum oder Objekt).
  • Elementliste
    Eine Liste von Feldern eines bestimmten Typs (z. B. Zeichenkette, Datum oder Objekt)
  • Mehrzeilig
    Ein mehrwertiges Feld vom Typ Zeichenkette.
  • Checkbox
    Ein oder mehrere Kontrollkästchen (Mehrfachselektion ist möglich).
  • Optionsfeld
    In einem Optionsfeld kann ein Wert aus mehreren ausgewählt werden (Radiobuttons).
  • Dropdown-Feld
    In einem Dropdown-Feld kann ein Wert aus mehreren ausgewählt werden.
  • Standard-Eigenschaft
    Bietet die Möglichkeit Standard-Eigenschaften von Objekten auch am benutzerdefinierten Formular anzuzeigen.
  • Trenner
    Dient zur Strukturierung von zusammengehörigen Eigenschaften.
  • HTML-Text
    Ermögliche formatierte Beschreibungen am Formular bereitzustellen.

Typen

Für Eingabefelder bzw. Elementlisten können Sie folgende Typen festlegen:

  • Zeichenkette
  • Ganze Zahl
  • Gleitkommazahl
  • Datum
  • Datum und Zeit
  • Zeitangabe
  • Nummerator
  • Hyperlink
  • Währung
  • Objekt

Hinweis: Der Typ eines Felds kann nicht mehr geändert werden, wenn das Formular veröffentlicht wurde.

Zusätzliche Einstellungen

Abhängig vom Typ können Sie weitere Einstellungen für die Formularfelder treffen. Im Allgemeinen können Sie festlegen:

Registerkarte „Allgemein“

  • Muss-Feld
  • Hilfetext
  • Initialisierungswert

Registerkarte „Erweitert“

  • Programmiername
  • Lesbarkeit bzw. Änderbarkeit abhängig von Benutzerrechten
  • Berechnungen, die das Verhalten beeinflussen (z. B. Sichtbarkeit des Felds berechnen)

Mehrsprachigkeit

Für die in Fabasoft Folio verfügbaren Sprachen können Sie Übersetzungen für die Namen und kontextsensitive Hilfe bereitstellen. Öffnen Sie dazu die Eigenschaften des Formulars (Kontextmenübefehl „Eigenschaften“) und wechseln Sie auf die Registerkarte „Übersetzungen“. Für jeden mehrsprachigen Namen des Formulars finden Sie einen entsprechenden Eintrag.

Kategorie

Wenn Sie ein benutzerdefiniertes Formular erstellen, können Sie bei der zugehörigen Kategorie das Feld Verwendbar für ändern. Wenn Sie zum Beispiel einen BPMN-Prozess auf eine derartige Kategorie einschränken und Aktivitäten verwenden möchten, die nur für Dokumente erlaubt sind, können Sie die Kategorie entsprechend anpassen.

WorkflowPermanenter Link zu dieser Überschrift

Der Workflow bietet folgende Neuerungen.

Mehr Übersicht im ArbeitsvorratPermanenter Link zu dieser Überschrift

Im Arbeitsvorrat-Dashboard werden in der Zu-tun-Liste neben der Aktivität auch die betroffenen Objekte angezeigt. Zusätzlich werden die betroffenen Objekte in einem eigenen Bereich angeführt.

ProzessverlaufPermanenter Link zu dieser Überschrift

Mithilfe des Workflows können Benutzer über Prozesse in die Bearbeitung von Geschäftsobjekten eingebunden werden. Prozesse bestehen aus einzelnen Aktivitäten, die im Arbeitsvorrat abgearbeitet werden können.

Um den Prozessverlauf einfach nachverfolgen zu können, steht bei Objekten, auf denen mindestens ein Prozess gestartet wurde, die Registerkarte „Prozesse“ zur Verfügung. Pro Prozess wird eine Übersicht über die bereits ausgeführten Aktivitäten und die aktuelle Aktivität angezeigt.

Klicken Sie auf den Prozessnamen, um den vollständigen Prozess mit eventuell vorhandenen Schleifen und Bedingungen anzuzeigen. Über fett dargestellte Linien wird der bereits durchgeführte Prozesslauf gekennzeichnet. Dabei nicht durchlaufene Pfade werden mit gestrichelten Linien visualisiert.

Über das Kontextmenü der Prozesselemente, können Sie die jeweils erlaubten Befehle ausführen. Zum Beispiel können Sie, wenn Sie über entsprechende Rechte verfügen, den betroffenen Teilnehmer einer noch nicht ausgeführten Aktivität über den Kontextmenübefehl „Bearbeiten“ ändern.

ProzessstatistikenPermanenter Link zu dieser Überschrift

Um einen Überblick über die laufenden Prozesse zu erhalten, steht Ihnen eine Vielzahl an Prozessstatistiken zur Verfügung, die die einzelnen Teilaspekte der Prozessausführung beleuchten.

Hinweis: Die Einstellungen können bei den Gruppen auf der Registerkarte „Workflow“ getroffen werden.

Die Statistiken können angezeigt werden für:

  • Prozessadministratoren
    Erhält einen Überblick über alle vordefinierten Prozesse und Ad-hoc-Prozesse der Organisation.
  • Prozesseigentümer
    Erhält einen Überblick über alle vordefinierten Prozesse, bei denen der Benutzer als Prozesseigentümer hinterlegt ist.
    Hinweis: Der Prozesseigentümer kann auf der Registerkarte „BPMN-Prozessdiagramm“ eines BPMN-Prozessdiagramms definiert werden.

Zu den Prozessstatistiken gelangen Sie über Ihren Arbeitsvorrat. Die Statistiken stehen für folgende drei Ebenen zur Verfügung: allgemeine Übersicht, Prozessdefinition, spezifischer Prozess.

Allgemeine Übersicht

  • Prozessstatistiken
    Bietet eine Übersicht über die Anzahl der laufenden Prozesse und der Prozesse in Verzug.
  • Prozessdurchsatz
    Zeigt die Anzahl der gestarteten und abgeschlossenen Prozesse und deren Differenz im ausgewählten Zeitraum.
  • Laufende Prozesse
    Zeigt die Anzahl der laufenden Prozesse und deren Veränderung im ausgewählten Zeitraum.
  • Laufende Prozesse je Prozessdefinition
    Zeigt die prozentuale Aufteilung der Prozessdefinitionen der laufenden Prozesse.
  • Aktivitäten der laufenden Prozesse
    Zeigt die prozentuale Aufteilung des Status der Aktivitäten der laufenden Prozesse.
  • Aktivitäten in Verzug
    Zeigt die prozentuale Aufteilung der Aktivitäten der laufenden Prozesse, die sich in Verzug befinden.
  • Beginndatum der laufenden Prozesse
    Zeigt die Anzahl der laufenden Prozesse gruppiert nach dem Beginndatum im ausgewählten Zeitraum.
  • Fälligkeit der Aktivitäten
    Zeigt die Aktivitäten der laufenden Prozesse, die in den nächsten zwei Wochen bearbeitet werden müssen.

Bezogen auf eine Prozessdefinition

  • Prozessdurchsatz
    Zeigt die Anzahl der gestarteten und abgeschlossenen Prozesse und deren Differenz im ausgewählten Zeitraum.
  • Laufende Prozesse
    Zeigt die Anzahl der laufenden Prozesse und deren Veränderung im ausgewählten Zeitraum.
  • Aktivitäten der laufenden Prozesse
    Zeigt die prozentuale Aufteilung des Status der Aktivitäten der laufenden Prozesse.
  • Aktivitäten in Verzug
    Zeigt die prozentuale Aufteilung der Aktivitäten der laufenden Prozesse, die sich in Verzug befinden.
  • Beginndatum der laufenden Prozesse
    Zeigt die Anzahl der laufenden Prozesse gruppiert nach dem Beginndatum im ausgewählten Zeitraum.
  • Fälligkeit der Aktivitäten
    Zeigt die Anzahl der Aktivitäten der laufenden Prozesse, die in den nächsten zwei Wochen bearbeitet werden müssen.
  • Prozesse
    Zeigt alle Prozesse (auch z. B. abgeschlossene Prozesse) der Prozessdefinition.

Bezogen auf einen Prozess

  • Laufzeit
    Zeigt die Laufzeit des Prozesses in Tagen im Vergleich zur durchschnittlichen Laufzeit der zugrundeliegenden Prozessdefinition.
  • Aktivitäten
    Zeigt die prozentuale Aufteilung des Status der Aktivitäten des Prozesses.
  • Übersicht
    Zeigt die wichtigsten Metadaten des Prozesses.

Hinweis: Über die Aktion „Einstellungen“ kann der Zeitraum (von letzter Woche bis letztes Jahr) der zeitabhängigen Statistiken festgelegt werden.

Arbeiten mit BPMN 2.0Permanenter Link zu dieser Überschrift

Fabasoft Folio unterstützt für die Geschäftsprozessmodellierung den internationalen Standard BPMN 2.0 (Business Process Model and Notation). Neben dem runderneuerten BPMN-Editor, der Ihnen eine einfache grafische Modellierung ermöglicht, können Sie die Geschäftsprozesse direkt mit der Workflow-Engine ausführen. Sie erhalten einen auf Ihr Unternehmen abgestimmten Workflow, ohne eine einzige Zeile programmieren zu müssen.

Mehrfach-Instanz-AktivitätenPermanenter Link zu dieser Überschrift

Mehrfach-Instanz-Aktivitäten ermöglichen Ihnen eine Aktivität von mehreren Prozessteilnehmern sequentiell oder parallel abarbeiten zu lassen. Sie können Mehrfach-Instanz-Aktivitäten in vordefinierten Prozessen und in Ad-hoc-Prozessen verwenden. Dadurch können Sie zum Beispiel eine parallele Freigabe durch mehrere Benutzer realisieren.

Vordefinierter Prozess (BPMN-Editor)

Im BPMN-Editor haben Sie die Möglichkeit bei einer Aufgabe den Schleifentyp festzulegen.

  • Keine Schleife
    Von der definierten Aktivität wird eine Instanz erzeugt, die den definierten Prozessteilnehmern im Arbeitsvorrat angeboten wird. Der erste Prozessteilnehmer, der die Bearbeitung beginnt, übernimmt die Aktivität und die Aktivität wird aus allen anderen Arbeitsvorräten entfernt.
  • MI parallel
    Von der definierten Aktivität werden für alle definierten Prozessteilnehmer eigene Instanzen erzeugt und parallel in den jeweiligen Arbeitsvorräten abgelegt. Alle Prozessteilnehmer müssen die Aktivität bearbeiten.
  • MI sequenziell
    Von der definierten Aktivität werden für alle definierten Prozessteilnehmer eigene Instanzen erzeugt und sequenziell in den jeweiligen Arbeitsvorräten abgelegt. Alle Prozessteilnehmer müssen nacheinander die Aktivität bearbeiten.

Als Prozessteilnehmer können Sie eine Verteilerliste, eine Organisationseinheit oder eine Eigenschaft des Objekts angeben, aus der eine Liste von Prozessteilnehmern ermittelt werden kann. Verteilerlisten können nur zusammen mit Mehrfach-Instanzen verwendet werden. Eine Organisationseinheit bzw. eine Eigenschaft des Objekts kann sowohl bei Mehrfach-Instanzen als auch bei Nicht-Mehrfach-Instanzen verwendet werden. Bei Mehrfach-Instanzen wird für jeden aufgelösten Prozessteilnehmer eine eigene Aktivitätsinstanz erzeugt, bei Nicht-Mehrfach-Instanzen nur eine Aktivitätsinstanz für die gesamte Organisationseinheit bzw. Eigenschaft des Objekts (einwertig). Mehrwertige Eigenschaften des Objekts sind nur bei Mehrfach-Instanzen erlaubt.

Ad-hoc-Prozess

Bei Ad-hoc-Prozessen können Sie ebenfalls zwischen „Keine Mehrfach-Instanz“, „Parallel“ und „Sequenziell“ wählen.

Hinweise

  • Verteilerlisten werden sofort beim Starten des Prozesses aufgelöst und somit werden die Prozessteilnehmer festgelegt. Bei Verwendung einer Eigenschaft des Objekts bzw. Organisationseinheit, werden die Prozessteilnehmer erst während der Laufzeit des Workflows aufgelöst (wenn die entsprechende Aktivität den Status „Kann beginnen“ erhält).
  • Wenn die Eigenschaft des Objekts einwertig ist und eine Organisationseinheit enthält, erhalten alle der Organisationseinheit direkt zugeordneten Benutzer jeweils eine Aktivität. Untergeordnete Organisationseinheiten werden nicht berücksichtigt.
  • Wenn die Eigenschaft des Objekts mehrwertig ist, erhalten alle direkt definierten Benutzer jeweils eine Aktivität. Zusätzlich erhalten alle direkt definierten Organisationseinheiten jeweils eine gemeinsame Aktivität.

Prozesse und FormularePermanenter Link zu dieser Überschrift

Wenn auf einem Dokument ein benutzerdefiniertes Formular definiert ist, wird beim Ausführen des Arbeitsschritts „Öffnen“ von Aktivitäten wie „Bearbeiten“ oder „Genehmigen“ eine zweigeteilte Sicht geöffnet. Somit können Sie das Dokument sichten und die Metadaten dazu direkt erfassen.

Wenn ein BPMN-Prozess auf die Kategorie eines benutzerdefinierten Basisformulars eingeschränkt ist, kann der Prozess auch für die vom Basisformular abgeleiteten Formulare verwendet werden.

Zusätzliche VerbesserungenPermanenter Link zu dieser Überschrift

Der Workflow bietet zusätzlich folgende neue Möglichkeiten:

  • Um Unterschriften leichter als Bedingung in BPMN-Prozessen definieren zu können, wurden die Eigenschaften Letzte Unterschrift, Letze Unterschrift am/um, Letzte Unterschrift von und Bemerkung der letzten Unterschrift eingeführt.
  • Die Eigenschaft Verwendbar für steht nun direkt im BPMN-Editor zur Verfügung. Wenn der Prozess auf eine Kategorie eines benutzerdefinierten Formulars oder auf eine Objektklasse eingeschränkt ist, können die definierten Felder im Bedingungseditor verwendet werden.
  • Im BPMN-Prozesseditor kann bei Aufgaben im Feld Ausdruck beim Erledigen der Aktivität eine app.ducx-Expression hinterlegt werden, die beim Erledigen der Aktivität ausgeführt wird.
  • Für die Definition eines abstrakten Teilnehmers eines Prozesses kann eine Eigenschaft des Objekts (z. B. Letzte Unterschrift von) herangezogen werden. Der Wert der Eigenschaft wird zur Laufzeit ausgewertet. Dies ist insbesondere für automatisch gestartete Prozesse nützlich, da abstrakte Teilnehmer wie Prozessinitiator in diesem Fall keinen Sinn machen.
  • Über den abstrakten Teilnehmer „Eigenschaft der Akte des Objekts“ kann der Teilnehmer somit auch über Eigenschaften der Akte des Objekts ermittelt werden.
  • Über ein Bedingungs-Zwischenereignis kann eine Warteaktion realisiert werden. Der Prozess wird erst fortgesetzt, wenn die Bedingung (app.ducx-Expression) erfüllt wurde. Über das Prüfungsintervall wird festgelegt, wie oft die Bedingung geprüft wird.
  • Wenn in Ad-hoc-Prozessen die Aktivitäten „Prüfen“, „Genehmigen“ bzw. „Freigeben“ verwendet werden, gilt Folgendes:
    • Negative Resultate (z. B. „Genehmigung verweigert“) werden über eine automatisch eingefügte Aktivität an denjenigen gemeldet, der den Ad-hoc-Prozess gestartet hat. Die restlichen gemeinsam vorgeschriebenen Aktivitäten, die noch nicht erledigt wurden, werden auf „Nicht ausgeführt“ gesetzt.
    • Aktivitäten für positive Resultate (z. B. „Freigegeben“) werden nur automatisch eingefügt, wenn es sich um die letzte Aktivität im Prozess handelt.
  • Werden bei laufenden Prozessen die Aktivitäten „Prüfen“, „Genehmigen“ bzw. „Freigeben“ eingefügt, werden negative Resultate an denjenigen gemeldet, der die Aktivitäten eingefügt hat. Die restlichen gemeinsam eingefügten Aktivitäten, die noch nicht erledigt wurden, werden auf „Nicht ausgeführt“ gesetzt.
  • BPMN-Bedingungs-Expressions werden mit NOCHECK ausgewertet. Dadurch werden Auswertungsfehler vermieden, dass Eigenschaften nicht der Objektklasse zugeordnet sind.
  • In den Workflow-Einstellungen im Feld Neuigkeiten über neue Aktivitäten im Welcome-Screen anzeigen können Sie festlegen, ob Neuigkeiten über neue Aktivitäten im Arbeitsvorrat im Welcome-Screen anzeigt werden (falls grundsätzlich aktiviert).
  • Die Aktivität „Prüfen“ steht nun zusätzlich zur Verfügung.
  • Mithilfe der Aktivität „Ausdruck im Hintergrund ausführen“ kann eine app.ducx-Expression im Hintergrund ausgeführt werden. Der Prozess wird erst fortgesetzt, wenn die Hintergrundaufgabe durchgeführt wurde.
  • Aktivität „Genehmigen und abschließen“
    Die zur Verfügung gestellten Standardaktivitäten wurden um die Aktivität „Genehmigen und abschließen“ erweitert. Beim Ausführen des Arbeitsschritts „Genehmigen und abschließen“ wird die Unterschrift „Genehmigen“ ausgeführt und das Objekt wird abgeschlossen, sodass keine Änderungen mehr möglich sind.
  • Die Aktivität „Anmerkung hinzufügen“ steht nun zusätzlich zur Verfügung. Somit können über den Workflow Anmerkungen mit Anhängen zu einem Objekt hinzugefügt werden.
  • Sie können festlegen, ob beim Beenden einer Aktivität im Arbeitsvorrat direkt die nächste Aktivität geöffnet wird, oder ob zurück in die Zu-tun-Liste navigiert wird (Kontomenü > „Erweiterte Einstellungen“ > „Workflow“ > Nach dem Beenden einer Aktivität automatisch die nächste Aktivität öffnen).

Verbesserte BedienbarkeitPermanenter Link zu dieser Überschrift

Die folgenden Neuerungen erleichtern die tägliche Arbeit mit Fabasoft Folio

Effizientes Arbeiten mit langen ListenPermanenter Link zu dieser Überschrift

Die Verzögerung bei der Darstellung von Listen mit sehr vielen Einträgen gehört der Vergangenheit an. Wenn Sie in eine Liste mit mehr als 250 Einträgen navigieren, werden nicht alle Einträge auf einmal geladen. Beim Scrollen durch die Liste werden die Einträge automatisch nachgeladen, sobald sie für den angezeigten Bereich benötigt werden. Dadurch kann der Webbrowser den gerade angezeigten Listenbereich viel schneller darstellen, das insbesondere bei Verwendung der Detailansicht Vorteile bringt.

Beim Navigieren mit dem Breadcrumb bzw. mit der Zurück-Funktionalität des Webbrowsers wird der zuletzt geöffnete Bereich der Liste angezeigt. Die Navigation mit der Tastatur ist ebenfalls problemlos möglich. Bild auf und Bild ab ändern den Fokus auf den ersten bzw. letzten sichtbaren Eintrag. Pos 1 bzw. Ende navigiert zum ersten bzw. letzten Eintrag in der Liste. Mit Alt + F9 gelangen Sie zum Spaltenkopf. Alt + A selektiert wie gewohnt alle Einträge und auch das Filtern berücksichtigt die gesamte Liste.

Auch wenn der Fabasoft Folio Webclient nun das Anzeigen von langen Listen optimal unterstützt, sollten Sie trotzdem unübersichtliche Listen vermeiden. Verwenden Sie deshalb weiterhin Ordner, um Ihre Ablage zu strukturieren.

Mit Listen im Eigenschaftseditor arbeitenPermanenter Link zu dieser Überschrift

Um die Komplexität des Eigenschaftseditors zu reduzieren und die Übersicht zu verbessern, steht nun für Objekt- und Aggregatslisten eine vereinfachte Darstellung zur Verfügung. Über die Schaltfläche „Details anzeigen“ gelangen Sie zu einer seitenfüllenden, für die Bearbeitung optimierten Gesamtansicht der Liste.

Vereinfachte Liste

Die reduzierten Bearbeitungsmöglichkeiten in der vereinfachten Liste ermöglichen einen verbesserten Überblick.

  • Es wird keine Menüleiste angezeigt.
  • Die Anzahl der angezeigten Einträge ist abhängig vom Kontext beschränkt. Im Allgemeinen werden maximal 15 Einträge angezeigt. Über die Schaltfläche „Weitere Einträge“ gelangen Sie zur Gesamtansicht.
  • Sortierungen und Gruppierungen können in der vereinfachten Liste nicht vorgenommen werden. Diese werden von den Einstellungen in der Gesamtansicht übernommen.
  • Es werden nur so viele Spalten angezeigt wie Platz zur Verfügung steht. Somit können horizontale Scrollbalken vermieden werden.
  • Vorschaubilder werden in der Detailansicht nicht angezeigt.
  • Aktionen auf den Einträgen können über das Kontextmenü durchgeführt werden.
  • Aktionen, die die Liste betreffen, können über Schaltflächen oberhalb der Liste angeboten werden.
  • Direktes Bearbeiten mit F2 ist abhängig von der Liste möglich.
  • Sind mehr Einträge vorhanden als auf einer Seite dargestellt werden können, werden die Spaltenüberschriften fixiert.

Gesamte Liste

Die gesamte Liste dient insbesondere für die Bearbeitung und ist über die Schaltfläche „Details anzeigen“ der vereinfachen Liste erreichbar. Wenn die Liste das einzige Feld auf einer Registerkarte ist, kann auch direkt die gesamte Liste angezeigt werden.

  • In der Gesamtansicht wird die Fensterbreite optimal ausgenutzt.
  • Die gesamte Liste bietet wie gewohnt die vollständige Listenfunktionalität.
  • Sind mehr Einträge vorhanden als auf einer Seite dargestellt werden können, werden die Spaltenüberschriften fixiert.

Verwendungsmöglichkeiten des KontextmenüsPermanenter Link zu dieser Überschrift

Sie wissen vielleicht, dass Sie auf beliebige Einträge in Listen ein Kontextmenü öffnen können, das Ihnen unterschiedliche Aktionen passend zu den markierten Listeneinträgen anbietet. Das Kontextmenü öffnen Sie mit der rechten Maustaste (bzw. als Tastaturnutzer mit der Menütaste bzw. mit der Tastenkombination Umschalttaste + F10).

Weniger bekannt ist hingegen,

  • dass Ihnen auch ein Kontextmenü im Fensterhintergrund zur Verfügung steht. Damit lassen sich unter anderem auch die Ansichten umschalten.
  • dass Sie über dem Namen in der Titelleiste das Kontextmenü des gerade angezeigten Dokuments bzw. Ordners öffnen können.
  • dass Sie auch in der Dokumentenansicht über einem Vorschaubild, Video- bzw. Audio-Element das Kontextmenü öffnen können.
  • dass Sie auf mobilen Geräten (Smartphones und Tablets) mit einem sogenannten „Long Touch“ (ca. zwei Sekunden den gewünschten Bereich berühren) das Kontextmenü ebenfalls nutzen können.

WiedervorlagenPermanenter Link zu dieser Überschrift

Mithilfe der Wiedervorlagen-Funktionalität können Sie festlegen, dass zur Erinnerung an eine zu erledigende Aufgabe eine E-Mail an einen Benutzer versendet wird oder ein Prozess gestartet wird.

Wiederlagen können Sie über den Kontextmenübefehl „Wiedervorlage erzeugen“ bzw. „Wiedervorlagen verwalten“ erzeugen. Neben der durchzuführenden Aktion müssen Sie auch das Datum für die Durchführung definieren. Bei dem Datum kann es sich um ein explizites Datum handeln oder um ein Datum das basierend auf einem Basisdatumsfeld berechnet wird. Zusätzlich können Sie festlegen, ob das Durchführungsdatum angepasst wird, wenn sich der Wert des Basisdatums ändert.

Beim Verwalten der Wiedervorlagen können Sie den Zeitraum festlegen, für den die Wiedervorlagen angezeigt werden sollen. Solange der Status der Wiedervorlage „Erzeugt“ ist, kann diese noch verändert werden.

Einen Überblick über alle Sie betreffenden Wiedervorlagen erhalten Sie im Widget „Wiedervorlagen“, welches sich direkt auf „Home“ befindet.

Ordner in Teamroom umwandelnPermanenter Link zu dieser Überschrift

Die Zugriffsrechte auf Teamrooms und auf die darin enthaltenen Objekte werden über das beim Teamroom definierte Team festgelegt. Ordner dienen der Strukturierung, haben jedoch keinen eigenen Rechtekontext.

Wenn Sie einem Ordner einen anderen Rechtekontext geben möchten, können Sie nun mithilfe des Kontextmenübefehls „Extras“ > „Umwandeln in Teamroom“ einen Ordner (der sich in einem Teamroom befindet) in einen Teamroom umwandeln. Umgekehrt können Sie auch einen Teamroom, der sich in einem anderen Teamroom befindet, in einen Ordner umwandeln.

Hinweis:

  • Um einen Ordner in einen Teamroom umzuwandeln, benötigen Sie alle Rechte in dem Teamroom, dem der Ordner zugeordnet ist.
  • Um einen Teamroom in einen Ordner umzuwandeln, benötigen Sie alle Rechte in diesem Teamroom und Änderungsrechte in dem Ziel-Teamroom für den Ordner.
    Wenn sich der umzuwandelnde Teamroom in mehreren Teamrooms befindet, können Sie den Ziel-Teamroom für den Ordner auswählen.

Publizieren von TeamroomsPermanenter Link zu dieser Überschrift

Beim erneuten Publizieren von Teamrooms haben Sie zusätzlich die Möglichkeit nur die Änderungen seit dem letzten Publizieren zu übertragen. Insbesondere bei Teamrooms mit vielen Inhalten und wenigen Änderungen profitieren Sie maßgeblich vom Geschwindigkeitsvorteil der Delta-Übertragung.

ZeitreisePermanenter Link zu dieser Überschrift

Die Zeitreise ist eine weitere Möglichkeit Versionen in der Vergangenheit zu betrachten. Über die Aktion „Zeitreise“ > „Zeitreise starten“ starten Sie die Zeitreise. Mithilfe der Zeitleiste gelangen Sie bequem und schnell zum gewünschten Zeitpunkt.

  • „Zeitreise starten“, „Zeitreise fortsetzen“, „Zeitreise beenden“
    Wählen Sie eine Version aus, die Sie betrachten möchten bzw. beenden Sie die Zeitreise. Alternativ zur Auswahl einer Version kann ein Zeitpunkt angegeben werden.
  • „Aktuelle Version sichern“
    Wenn Sie eine Version erstellen, wird der aktuelle Zustand gespeichert. Die Version kann auch als Freigabestand bereitgestellt werden. Somit können Teammitglieder mit Leseberechtigung nur mehr diese Version sehen. Durch einen neuen Freigabestand wird ein eventuell vorhandener Freigabestand ersetzt.
  • „Aufräumen“, „Löschen“
    Nicht mehr benötigte Versionen können gelöscht werden.
  • „Vergleichen“
    Vergleichen Sie die ausgewählte Version mit der aktuellen Version. Bei Word-Dokumenten kann auch der Inhalt verglichen werden.
  • „Wiederherstellen“
    Die aktuelle Version wird durch die ausgewählte Version ersetzt.

Zusätzliche VerbesserungenPermanenter Link zu dieser Überschrift

Die folgenden neuen Möglichkeiten stehen zusätzlich zur Verfügung:

  • Sobald ein Datumsfeld fokussiert wird, wird ein Kalender geöffnet, der eine effiziente Auswahl des gewünschten Datums ermöglicht.
  • Durch die Verwendung von Standardlisten für die Anzeige des Mindbreeze-Suchergebnisses steht Ihnen auch in Trefferlisten die gewohnte Funktionalität zur Verfügung. Zum Beispiel können Sie die Sicht ändern oder zusätzliche Spalten einblenden.
  • Die Dokumentenansicht kann in den Vollbildmodus geschalten werden, um zum Beispiel für Bilder den gesamten Bildschirm nutzen zu können.
  • Das Inhaltsverzeichnis bei der PDF-Ansicht eines Teamrooms wird bis zur zwanzigsten Ebene angezeigt.
  • In den Eigenschaften eines Teamrooms können Sie auf der Registerkarte „Inhaltseinstellungen“ festlegen, ob für PDF-Ansichten von Dokumenten, die dem Teamroom zugeordnet sind, ein Deckblatt generiert werden soll. Sie können dabei auswählen, welche Versionen bzw. Unterschriften am Deckblatt angezeigt werden sollen.
  • Bei Ordnern steht nun ebenfalls der Kontextmenübefehl „Extras“ > „Zu Teamroom-Vorlagen hinzufügen“ zur Verfügung.
  • In die Zwischenablage kopierte Objekte werden ebenfalls im Verlauf berücksichtigt.
  • Wenn Sie mehrere Objekte markieren und den Kontextmenübefehl „Umbenennen“ ausführen, wird nacheinander für jedes markierte Objekt ein Umbenennen-Dialog geöffnet. Bei einem Klick auf „Abbrechen“ werden alle Änderungen verworfen.
  • Das Layout der PDF-Übersichten wurde vollständig überarbeitet und entspricht nun dem Eigenschaftsdialog des Webclients. In den Fabasoft Folio Apps sind die PDF-Übersichten für den Formfaktor von mobilen Endgeräten optimiert. Selbstverständlich wurde auf die Barrierefreiheit der PDF-Dokumente geachtet.
  • Die Hervorhebungsfarbe von Objekten wird nun in allen Listenansichten angezeigt. Festlegen können Sie die Hervorhebungsfarbe über das Kontextmenü. Wenn Sie auf Bedienungshilfen angewiesen sind, erhalten Sie über „Grundeinstellungen“ > Registerkarte „Bedienungshilfen“ > Textalternative für farblich hervorgehobene Felder anzeigen eine textuelle Kennzeichnung. In der Detailansicht können Sie die Spalte „Hervorhebungsfarbe“ einblenden.
  • Um Tastaturanwender zu unterstützen, wird der Fokusrahmen aktiviert, sobald eine beliebige Navigationstaste betätigt wird.
  • Wenn Sie sich im Arbeitsvorrat befinden und zu den betroffenen Objekten navigieren, bleibt der Arbeitsvorrat-Kontext erhalten auch wenn Sie die Zurück-Schaltfläche des Webbrowsers verwenden.
  • Anmerkungen können nun auch standardmäßig über den Kontextmenübefehl „Extras“ > „Anmerkungen“ zu Objekten hinzugefügt werden.
  • In der Detailansicht können bis zu 50 Spalten eingeblendet werden (anstatt 25).
  • Wenn Sie den Menübefehl „Zwischenablage“ > „Datentabelle“ > „Kopieren“ ausführen, werden, falls Zeilen markiert sind, nur diese in die Zwischenablage übernommen. Die Reihenfolge, in der die Zeilen markiert wurden, wird dabei berücksichtigt.
  • Die neue Objektklasse „CAD-Zeichnung“ ist für folgende Dateitypen vorgesehen: dwg, dwf, dxf, CATDrawing, CATPart, CATProduct.
  • Die Objektklasse „Inhalt (unbekannter Typ)“ wurde in „Inhalt“ umbenannt.
  • Um optimale Spaltenbreiten in Listen sicherzustellen, werden diese standardmäßig dynamisch anhand der Länge der Werte in den Spalten ermittelt. Wenn Sie die Spaltenbreiten manuell festlegen oder Voreinstellungen für die jeweiligen Formulare existieren, erfolgt keine dynamische Breitenanpassung. Sie können jedoch die Breite durch einen Doppelklick auf den Bereich zwischen zwei Spalten im Spaltenkopf manuell optimieren.
  • Bei der Eingabe einer Suchanfrage werden nun Vorschläge angezeigt.
  • Orientierung von Bildern wird berücksichtigt
    Wenn bei Bildern die EXIF-Information für die Orientierung vorhanden ist, wird diese bei der Anzeige der Vorschaubilder berücksichtigt. Das Bild an sich wird dabei nicht verändert.
  • XPS- bzw. OXPS-Dateien (XML Paper Specification) werden unterstützt und können im Microsoft XPS Viewer geöffnet werden.
  • Entsprechend der Web Content Accessibility Guidelines (WCAG) wurden die Diagramme überarbeitet, um Benutzern mit visueller Beeinträchtigung besser zu unterstützen.
  • Wenn Sie in einer Liste ein Feld mit F2 bearbeiten, wird durch einen Klick außerhalb des Bearbeitungsfelds die Änderung gespeichert. Falls der Klick auf einem klickbaren Element erfolgt, wird zusätzlich die entsprechende Aktion ausgeführt.
  • Spaltenbearbeitung in der Detailansicht
    Sie können die in der Detailansicht eingeblendeten Felder direkt mit F2 bearbeiten, ohne die Eigenschaften der jeweiligen Objekte öffnen zu müssen. Neben einwertigen Feldern können Sie jetzt auch mehrwertige Felder (Listen, Aggregate) bearbeiten. Dabei wird ein Overlay zur Eingabe der Daten geöffnet.

Drittprodukt-IntegrationPermanenter Link zu dieser Überschrift

Die Drittprodukt-Integration bietet folgende Neuerungen.

PDF-Dokumente annotierenPermanenter Link zu dieser Überschrift

Annotierungen, die Sie an einem PDF-Dokument mithilfe eines externen PDF-Viewers anbringen, können aus dem PDF-Dokument herausgelöst und in einer öffentlichen bzw. persönlichen Ebene gespeichert werden. Somit muss das Dokument nicht dupliziert werden, wenn Sie allgemeine Kommentare mit anderen Teammitgliedern teilen möchten aber zusätzlich persönliche Anmerkungen nur für Sie einsehbar sein sollen.

Um öffentliche Annotierungen zu erstellen, bearbeiten Sie wie gewohnt das PDF-Dokument (z. B. Aktion „Bearbeiten“). Im externen PDF-Viewer können Sie die entsprechenden Annotierungen anbringen und das Dokument wieder speichern.

Um persönliche Annotierungen zu erstellen, navigieren Sie in das PDF-Dokument. Über die Schaltflächen „Kommentarleiste einblenden“ und „Kommentieren“ der PDF-Vorschau können Sie das PDF-Dokument zur Bearbeitung öffnen. Die im externen PDF-Viewer angebrachten Annotierungen werden als persönliche Annotierungen gespeichert.

Beachten Sie:

  • Falls sich der PDF-Inhalt an sich ändert (z. B. durch ein Ersetzen mit einer anderen Datei), stehen weiterhin die vorhergehenden Dokumente inklusive Annotierungen zur Verfügung. Die Dokumente können über ein Drop-down-Feld in der PDF-Vorschau ausgewählt werden
  • Wenn das PDF-Dokument beim Import bereits Annotierungen aufweist, werden diese, wenn Sie die Kommentarleiste einblenden, in einer öffentlichen Ebene gespeichert und sind somit für alle Teammitglieder sichtbar.
  • Wenn Sie ein PDF-Dokument herunterladen, wird der PDF-Inhalt mit den für Sie sichtbaren Annotierungen versehen.
  • Bei Teamrooms kann auf der Registerkarte „Inhaltseinstellungen“ im Feld Kommentare erlauben festgelegt werden, ob Annotierungen auf PDF-Dokumenten des Teamrooms angebracht werden können. Bei PDF-Dokumenten, die nicht Teamrooms zugeordnet sind, sind Annotierungen immer erlaubt.

Integration in Microsoft OfficePermanenter Link zu dieser Überschrift

Die Integration in Microsoft Office ermöglicht, Aktionen direkt aus der Anwendung heraus auszuführen.

Die Domänen- und Kontoauswahl kann direkt im Office-Produkt getroffen werden. Somit können Sie zum Beispiel sehr einfach mehrere Installationen gleichzeitig nutzen.

Integration in Microsoft OutlookPermanenter Link zu dieser Überschrift

Die Integration in Microsoft Outlook bietet Ihnen die folgenden Möglichkeiten.

  • In Microsoft Outlook auf der Registerkarte „Start“ können Sie in der Gruppe „Fabasoft Folio“ über die Schaltfläche „E-Mail hochladen“ die markierten E-Mails in einen Teamroom bzw. Ordner hochladen. Bei der Auswahl des Ordners ermöglicht Ihnen die Schaltfläche „Ordner wählen“ auch einen neuen Teamroom bzw. Ordner zu erzeugen.
    Alternativ können Sie wie gewohnt E-Mails kopieren (Strg + C) und in Fabasoft Folio einfügen (Strg + V).
  • Beim Erstellen einer E-Mail steht Ihnen in der Gruppe „Fabasoft Folio“ die Schaltfläche „Zugriff prüfen“ zur Verfügung. Dadurch können Sie überprüfen, ob die angeführten Empfänger Zugriff auf die in der E-Mail verlinkten Folio-Objekte haben. Über die Schaltfläche „Jetzt prüfen“ können Sie manuell die Überprüfung durchführen. Aktivieren Sie die Option „Immer beim Senden prüfen“, um die Überprüfung automatisiert durchzuführen.
  • Das Generieren von PDF-Übersichten und das Extrahieren von Metadaten von E-Mails kann nun unabhängig vom Client direkt in Fabasoft Folio erfolgen.  Sie können somit zum Beispiel eine E-Mail in einem Folio-Netzlaufwerk ablegen und die Metadaten werden dennoch extrahiert.
  • In Fabasoft Folio wird bei E-Mails die Wichtigkeit (hoch bzw. niedrig) als Statussymbol angezeigt.

Kontaktsynchronisation mit Microsoft OutlookPermanenter Link zu dieser Überschrift

Sie können Kontakte, die Sie in Fabasoft Folio verwalten, mit Microsoft Outlook synchronisieren. Im Kontextmenü des Fabasoft Folio Benachrichtigungssymbols steht dazu der Befehl „Folio Adressbuch öffnen“ zur Verfügung (wenn in der Arbeitsumgebung konfiguriert). Ihre Adressbuchliste wird in Microsoft Outlook unter „Kontakte“ hinzugefügt und automatisch synchron gehalten. Über den Kontextmenübefehl „Synchronisieren“ des Fabasoft Folio Benachrichtigungssymbols, können Sie die Synchronisierung auch manuell durchführen.

Hinweis:

  • Ihre Adressbuchliste finden Sie unter „Kontomenü (Ihr Benutzername)“ > „Erweiterte Einstellungen“ > „Adressbuch“. Hier können Sie Ihre Kontakte verwalten und weitere Adressbücher anlegen.
  • Kontakte können von Fabasoft Folio nach Microsoft Outlook synchronisiert werden jedoch nicht umgekehrt. Die Kontakte stehen in Microsoft Outlook lesend zur Verfügung.

Integration in Microsoft WordPermanenter Link zu dieser Überschrift

Die Integration in Microsoft Word bietet Ihnen die folgenden Möglichkeiten.

Schaltflächen

Sie können direkt von Microsoft Word aus, Aktionen in Fabasoft Folio durchführen. Dazu steht Ihnen die Registerkarte „Fabasoft Folio“ zur Verfügung, die abhängig vom Kontext die entsprechenden Aktionen anbietet.

  • Öffnen
    Sie können ein Dokument in Fabasoft Folio auswählen und in Microsoft Word öffnen.
  • Hochladen
    Wenn das aktuelle Dokument nicht über Fabasoft Folio geöffnet wurde, kann dieses in Fabasoft Folio hochgeladen werden. Sie können einen Speicherort in Fabasoft Folio auswählen und die Bearbeitung direkt fortsetzen, ohne das Dokument schließen zu müssen.

Hinweis: In Microsoft PowerPoint und Microsoft Excel stehen Ihnen auf der Registerkarte „Fabasoft Folio“ ebenfalls die „Öffnen“- und „Hochladen“-Schaltflächen zur Verfügung.

Formulare und Felder

Wenn Sie bei einem Word-Dokument ein benutzerdefiniertes Formular hinterlegen, können Sie die von Ihnen definierten Eigenschaften als aktualisierbare und änderbare Felder (abhängig vom Eigenschaftstyp) im Word-Dokument einfügen. Dazu steht in Microsoft Word auf der Registerkarte „Fabasoft Folio“ die Schaltfläche „Feld einfügen“ zur Verfügung.

Folgende Eigenschaftstypen sind im Word-Dokument bearbeitbar:

  • Ganzzahl
  • Zeichenkette (auch mehrzeilig)
  • Datum
  • Datum und Zeit
  • Boolesche Eigenschaft
  • Aufzählung

Die weiteren Eigenschaftstypen werden als nur lesbare Felder dargestellt.

Hinweis:

  • Beim Speichern des Inhalts werden in der PDF-Ansicht die Felder automatisch aktualisiert, unabhängig davon ob die PDF-Ansicht am Server oder am Client generiert wird.
  • Auf der Registerkarte „Inhalt“ des Word-Dokuments können Sie in der Eigenschaft PDF-Inhalt bei Datenänderung aktualisieren festlegen, ob auch bei Änderungen der Metadaten die PDF-Ansicht am Server neu generiert wird. Somit werden Felder, die sich auf die Metadaten des Dokuments beziehen, mit aktualisierten Werten dargestellt.
  • Die Eigenschaften Letzte Unterschrift, Letzte Unterschrift am/um, Letzte Unterschrift von und Bemerkung der letzten Unterschrift können als Felder in Word-Dokumenten eingefügt werden.
  • Wenn Sie ein benutzerdefiniertes Formular mit Basisklasse „Container mit Benutzerdaten“ bzw. „Room mit Benutzerdaten“ erzeugen, können Sie zusätzlich festlegen, ob es sich um eine Akte handelt. Bei den untergeordneten Objekten wird der Bezug zur Akte gespeichert. Dadurch ist es zum Beispiel möglich, dass die Eigenschaften der Akte auch als Felder in Microsoft Word zur Verfügung stehen.

PDF-Ansicht

Sie haben die Möglichkeit, dass die PDF-Ansicht von Microsoft Office-Dokumenten lokal generiert wird. Dies hat den Vorteil, dass die Abbildungstreue zwischen Dokument und PDF-Dokument viel besser gewährleistet ist, wenn am Konvertierungsserver statt Microsoft Office nur LibreOffice zur Verfügung steht.

Ob Sie die PDF-Ansicht am Arbeitsplatz oder am Konvertierungsserver generieren wollen, können Sie in den Optionen des Fabasoft Folio Clients einstellen. Öffnen Sie dazu das Kontextmenü des Benachrichtigungssymbols des Fabasoft Folio Clients und klicken Sie auf „Optionen“. Auf der Registerkarte „Inhalt“ können Sie Folgendes festlegen:

Dokumente

  • PDF-Ansicht am Arbeitsplatz erzeugen
    • Microsoft Word
    • Microsoft Excel
    • Microsoft PowerPoint
    • Microsoft Visio

Fabasoft Folio ClientPermanenter Link zu dieser Überschrift

Der Fabasoft Folio Client bietet Ihnen folgende neuen Möglichkeiten.

BenutzeroberflächePermanenter Link zu dieser Überschrift

Durch einen Klick auf das Benachrichtigungssymbol des Fabasoft Folio Clients gelangen Sie zur Übersicht über die zuletzt verwendeten Dokumente.

  • Kopfzeile
    Wenn Sie mit mehreren Installationen arbeiten, können Sie über die Kopfzeile zwischen diesen wechseln. Durch einen Klick auf das Fragenzeichen, wird der Support-Dialog geöffnet. Über das Zahnradsymbol gelangen Sie zu den weiterführenden Optionen.
  • Fußzeile
    In der Fußzeile können Sie die Synchronisierung erstmalig starten bzw. sehen Sie den aktuellen Status der Synchronisierung. Durch einen Klick auf den Synchronisierungsstatus können Sie die Synchronisierung pausieren.
  • Dokumentübersicht
    Die offenen, zuletzt bearbeiteten, umbenannten, heruntergeladenen bzw. hochgeladenen Dokumente werden chronologisch angezeigt. Tritt ein Fehler beim Synchronisieren auf, wird die betroffene Datei mit einem roten Hintergrund dargestellt.
    Über das Kontextmenü des jeweiligen Dokuments können Sie
    • bei einem synchronisierten Dokument den Windows Explorer öffnen,
    • den Fabasoft Folio Webclient mit dem Dokument öffnen bzw.
    • den Link auf das Dokument in die Zwischenablage kopieren.

Fabasoft Folio Client auf UbuntuPermanenter Link zu dieser Überschrift

Der Fabasoft Folio Client ist nun auch auf Ubuntu verfügbar. Somit können Sie auch unter Ubuntu bequem über das Benachrichtigungssymbol Einstellungen treffen und die zuletzt verwendeten Dokumente anzeigen.

TastaturbedienungPermanenter Link zu dieser Überschrift

Der Fabasoft Folio Client lässt sich vollständig mit der Tastatur bedienen. Wenn Sie das Benachrichtigungssymbol fokussieren, gelangen Sie mit der Leertaste in die Dokumentenübersicht der zuletzt verwendeten Dokumente. Tabulator und Pfeiltasten dienen zur Navigation. Das Kontextmenü zu den einzelnen Einträgen können Sie über die Menütaste öffnen.

SynchronisierungPermanenter Link zu dieser Überschrift

Die Synchronisierung von Dokumenten mit dem lokalen Dateisystem bietet folgende neue Möglichkeiten:

  • Die für die Synchronisierung verwendete Bandbreite kann im Optionen-Dialog des Fabasoft Folio Clients eingeschränkt werden.
  • Falls sich in einem Ordner nicht synchronisierte Dokumente befinden und Sie den Kontextmenübefehl „Folio Ordner“ > „Lokale Dateien entfernen“ ausführen, werden Sie darauf hingewiesen. Bei erneutem Ausführen des Kontextmenübefehls werden die nicht synchronisierten Dokumente entfernt und zur Sicherung unter \Users\<user>\Documents\My Recovered Documents abgelegt.
  • Falls Sie den Download einer zu großen Datei abbrechen möchten, können Sie am übergeordneten Ordner den Kontextmenübefehl „Folio Ordner“ > „Lokale Dateien entfernen“ ausführen.
  • Auf Apple macOS ist es möglich Dateien mit einem Tag zu versehen. Bei Verwendung des Fabasoft Folio Ordners werden Tags nun auch synchronisiert.
  • Beim Synchronisieren von Dokumenten bzw. Ordnern in das Dateisystem werden Verknüpfungen berücksichtigt. Jede Dokument-Verknüpfung wird als vollständige Datei synchronisiert und Änderungen werden an allen Stellen nachgezogen. Zusätzlich wurde die Statusanzeige des Fabasoft Folio Clients erweitert.

Hinweis: Falls Sie noch die alte Synchronisierung nutzen, muss der Folio Ordner neu erstellt werden. Beim erstmaligen Synchronisieren mit der aktuellen Version, wird ein entsprechender Hinweis angezeigt. Bei der Aktualisierung wird der bestehende Folio Ordner mitsamt allen Inhalten gelöscht. Sichern Sie daher alle nicht synchronisierten Dateien bevor Sie die Aktualisierung bestätigen.

LAN-SynchronisierungPermanenter Link zu dieser Überschrift

Standardmäßig erfolgt die Synchronisierung mit Fabasoft Folio. Alternativ können Sie auch die LAN-Synchronisierung aktivieren.

Wenn sich Daten in Fabasoft Folio ändern, werden zuerst alle Folio Ordner im lokalen Netzwerk kontaktiert, ob die geänderten Daten bereits lokal vorliegen. Ist dies der Fall, werden die Daten über das LAN synchronisiert und nicht über die Folio-Installation. Die Sicherheit ist in beiden Fällen durch Verschlüsselung gewährleistet.

Um die LAN-Synchronisierung nutzen zu können, müssen Sie diese aktivieren:

  1. Öffnen Sie das Kontextmenü des Fabasoft Folio Benachrichtigungssymbols und klicken Sie auf „Optionen“.
  2. Auf der Registerkarte „Bandbreite“ können Sie die LAN-Synchronisierung aktivieren.
    • Die LAN-Synchronisierung sollte nur in vertrauenswürdigen Netzwerken verwendet werden.
    • Stellen Sie unter Microsoft Windows sicher, dass das Netzwerk vom Typ „Domänennetzwerk“ bzw. „Privates Netzwerk“ (Netzwerk- und Freigabecenter) ist. Andernfalls können Sie die LAN-Synchronisierung nicht aktivieren.
    • Unter macOS können Sie die LAN-Synchronisierung für das aktuelle Netzwerk aktivieren.

Hinweis:

  • Die Clients müssen sowohl mit dem LAN (gleiches Subnetzwerk) als auch mit Fabasoft Folio verbunden sein.
  • Für die Kommunikation wird der TCP-Port 17096 und die IP-Multicast-Adresse 224.0.0.202 bzw. ff02::1 (lokales Subnetzwerk) verwendet. Gegebenenfalls müssen entsprechende Einstellungen in der Firewall getroffen werden. Sollten Sie Probleme mit der LAN-Synchronisierung haben, wenden Sie sich bitte mit diesen Informationen an Ihren Netzwerkadministrator.

Administration des Fabasoft Folio ClientsPermanenter Link zu dieser Überschrift

Als Windows-Administrator können Sie die Optionen des Fabasoft Folio Clients für Ihre Benutzer zentral festlegen. Dazu kann für jede Einstellung im Optionen-Dialog ein entsprechender Registry-Wert definiert werden.

Nähere Informationen finden Sie im White Paper „Fabasoft Folio Client“.

Zusätzliche VerbesserungenPermanenter Link zu dieser Überschrift

Der Fabasoft Folio Client bietet zusätzlich folgende neue Möglichkeiten:

  • E-Mails können direkt aus IBM Notes per Drag-and-drop in Fabasoft Folio abgelegt werden. Alternativ kann der Menübefehl „Aktionen“ > „E-Mail hochladen (Fabasoft Folio)“ verwendet werden.
  • Der Fabasoft Folio Client für Apple macOS bietet zusätzlich den Kontextmenübefehl “Folio-Kalender öffnen”. Dadurch kann die Verbindung zum Folio-Kalender ohne manuellen Konfigurationsaufwand sehr einfach hergestellt werden.
  • Archive im 7z-Format können mit dem Drittprodukt 7-Zip direkt aus Fabasoft Folio geöffnet werden. Als Vorschau steht analog zum ZIP-Format das Inhaltsverzeichnis des Archivs zur Verfügung.
  • Dokumente können direkt von einer Folio- bzw. Private-Cloud-Installation mit „Kopieren und Einfügen“ in Fabasoft Folio abgelegt werden.

Allgemeine VerbesserungenPermanenter Link zu dieser Überschrift

  • Das Kontomenü (Ihr Benutzername) wurde neu strukturiert. In den Untermenüs „Erweiterte Einstellungen“ und „Status“ finden Sie die weniger oft benötigten Befehle.
  • Unter „Kontomenü (Ihr Benutzername)“ > „Erweiterte Einstellungen“ > „Benachrichtigungen“ können Sie festlegen, über welche Ereignisse Sie informiert werden möchten. Sie können entweder per E-Mail informiert werden oder per Neuigkeiten beim Teamroom (Aktion „Neuigkeiten anzeigen“).
    Auf der Registerkarte „Benachrichtigungen“ bzw. „Deaktivierte Benachrichtigungen“ definieren Sie, zu welchen Teamrooms bzw. Dashboards Sie Benachrichtigungen erhalten möchten. Bei den eingetragenen Objekten gilt die Einstellung für die gesamte Hierarchie, falls nicht für ein untergeordnetes Objekt eine andere Einstellung getroffen wurde.
  • Bei Verwendung von Bildschirmleseprogrammen können Sie festlegen, dass wohlbekannte englischsprachige Begriffe speziell ausgezeichnet werden, um eine korrekte Aussprache zu gewährleisten („Kontomenü (Ihr Benutzername)“ > „Grundeinstellungen“ > Registerkarte „Bedienungshilfen“ > „Fremdsprachige Ausdrücke für Sprachausgabe aufbereiten“).
  • Im Hintergrund-Kontextmenü steht zusätzlich der Befehl „Suchen“ zur Verfügung.
  • Objekte, die anderen Teamrooms zugeordnet sind, können auch als Teamroom-Vorlagen verwendet werden. Stellen Sie sicher, dass die Teammitglieder in den anderen Teamrooms berechtigt sind, damit diese die Vorlagen verwenden können.
  • In den Eigenschaften des Teamrooms, auf der Registerkarte „Teamroom“ können Sie im Feld Herunterladen bzw. Öffnen von Inhalten am Arbeitsplatz einschränken die Teammitglieder anhand der Teamroom-Rollen einschränken, die die Aktionen bzgl. Bearbeiten und Herunterladen im Webbrowser-Client angeboten bekommen.
  • In Suchordnern kann nach Papierkorb (Teamroom) gesucht werden, um auch eine große Anzahl an Papierkörben effizient entleeren zu können.
  • Für Suchordner stehen die Aktionen „Suchmuster erzeugen“ bzw. „Suchmuster bearbeiten“ und „Eigenschaften“ zusätzlich zur Verfügung. Somit können Sie Suchordner einfach konfigurieren.
  • Wenn Sie ein benutzerdefiniertes Formular als Akte definieren, stehen Ihnen automatisch aktentypische Aktionen wie „Ersetzen“, „Abschließen“, „Stornieren“ und „Wiederherstellen“ zur Verfügung.
  • Für benutzerdefinierte Formulare kann ein Basisformular definiert werden. Dadurch werden die Formularseiten und Felder des Basisformulars übernommen. Zusätzlich können für Felder Expressions hinterlegt werden: Sichtbarkeit des Felds berechnen, Wert des Felds berechnen, Änderbarkeit des Felds berechnen, Änderung des Werts behandeln und Wert prüfen.
  • Beim Erstellen von benutzerdefinierten Formularen können Felder per Drag-and-drop bzw. mithilfe des Kontextmenübefehls „Verschieben“ von einer Registerkarte auf eine andere verschoben werden.
  • Die angezeigten Eigenschaften auf der Registerkarte „Allgemein“ von Objekten wurden überarbeitet und konsolidiert.
  • In der Zeitreise kann alternativ zur Auswahl einer Version ein Zeitpunkt angegeben werden.
  • Beim Herunterladen eines Ordners enthält ab nun die generierte ZIP-Datei den Inhalt des Ordners auf oberster Ebene und nicht den Ordner selbst. Dies hilft Probleme mit langen Pfadnamen zu reduzieren.
  • Wenn Standard-Hintergrundaufgaben einer Kategorie bereits beim Zuweisen der Kategorie auszuführend sind, werden diese sofort ausgeführt und nicht erst zeitverzögert durch eine automatische Aufgabe.
  • Bei Standard-Hintergrundaufgaben kann mithilfe des Felds Datum bei Basisdatumsänderung neu berechnen festgelegt werden, ob der Zeitpunkt zur Ausführung der Hintergrundaufgabe bei einer Änderung des Basisdatums neu festgelegt wird. Noch nicht ausgeführte Hintergrundaufgaben werden zum neu berechneten Zeitpunkt ausgeführt bzw. bereits ausgeführte Hintergrundaufgaben werden erneut ausgeführt.
  • Beim Definieren von Wiedervorlagen, Hintergrundaufgaben und Aufbewahrungsfristen können auch Datumseigenschaften von benutzerdefinierten Formularen ausgewählt werden. Die angebotenen Eigenschaften werden abhängig vom Kontext gefiltert. Zusätzlich kann angegeben werden, ob die Zeitspanne vom Basisdatum abgezogen bzw. hinzuaddiert wird (z. B. 3 Tage vor „Gültig bis“, 2 Jahre nach „Erzeugt am/um“).
  • Das Herunterladen von großen Dateien startet viel schneller, da die Konsistenz der Dateien während des Herunterladens geprüft wird und nicht vor dem Start.
  • Beliebige Objekte als Favoriten
    Sie können zu Ihren Favoriten beliebige Objekte (zum Beispiel auch einzelne Dokumente) hinzufügen.
  • Die W3C-Empfehlung „SOAP Message Transmission Optimization Mechanism“ (https://www.w3.org/TR/soap12-mtom/) wird unterstützt.
  • Beim Import von E-Mails (EML bzw. MSG) können Anhänge nun serverseitig herausgelöst werden. Für diese Funktionalität ist somit am Client weder Microsoft Outlook noch der Fabasoft Folio Client nötig.

AdministrationPermanenter Link zu dieser Überschrift

  • Bei einem Mandanten können nun ebenfalls Domänen-Voreinstellungen im Workflow hinterlegt werden. Die Auswertungskette ist somit: Arbeitsumgebung, Benutzer, Gruppe, Mandant und Workflow-Konfiguration.
  • In der Workflow-Konfiguration auf der Registerkarte „Aktivitäten“ steht das Feld Löschen von Aktivitäten aus dem Arbeitsvorrat zur Verfügung. Damit können Sie festlegen, wer Aktivitäten (mit Status Warten auf Vorlage, Kann beginnen, Begonnen, Warten auf externe Synchronisation“ und „Suspendiert“) in laufenden Prozessen löschen darf.
  • Die Fabasoft Folio RPM-Pakete sind mit einem GPG-Schlüssel signiert (https://www.gnupg.org). Mithilfe der Signatur kann sichergestellt werden, dass die Pakete nicht kompromittiert wurden.
    Weiterführende Information finden Sie im White Paper “Fabasoft on Linux - Installation of Fabasoft Folio Services”.
  • In der vApp-Konfiguration kann auf der Registerkarte „Web-Service-Sicherheit“ im Feld X-XSS-Protection Header der gewünschte Wert („0“, „1“, „1; mode=block“ oder „1; report=<reporting-URI>“) festgelegt werden.
  • Für ein Skript, das in der ersten Zeile den Kommentar LANGUAGE="JavaScript" enthält, wird nun auf Microsoft Windows und Linux die ADE-KJS-JavaScript-Engine verwendet. In früheren Versionen wurde in diesem Fall auf Microsoft Windows die Windows-JavaScript-Engine verwendet. Um das alte Verhalten zu erreichen, kann der Kommentar LANGUAGE="JScript" verwendet werden.

AbkündigungPermanenter Link zu dieser Überschrift

Folgende Funktionalität ist nicht mehr verfügbar:

  • Tastenkombinationen für Menüs sind nicht länger verfügbar.
  • Die Benutzeroberfläche wurde durch eine neue ersetzt. Softwarekomponenten und Objekte zugehörig zur alten Benutzeroberfläche wurden entfernt (z. B. FSCVAPP@1.1001:XML, FSCVAPP@1.1001:ColorScheme, FSCFOLIOTHEMES@1.1001).
  • Das CMSPortlet und die Softwarekomponenten Integration for Blogs (FSCBLOGS@1.1001), Integration for Message Boards (FSCMBOARD@1.1001), Integration for Wikis (FSCWIKI@1.1001) und Integration for Liferay Portal (FSCLIFERAY@1.1001) sind nicht länger verfügbar.

Folgende Drittprodukte werden nicht mehr unterstützt:

  • Kofax Capture 10.0.2 wird nicht mehr unterstützt.
  • Microsoft Windows Server 2012 R2 wird nicht mehr unterstützt.
  • Microsoft SQL Server 2014 SP2 wird nicht mehr unterstützt.
  • Microsoft Office 2010 SP2 wird nicht mehr unterstützt.
  • Microsoft Visio 2010 SP2 wird nicht mehr unterstützt.
  • Microsoft Project 2010 SP2 wird nicht mehr unterstützt.
  • Microsoft Windows 7 SP1 wird nicht mehr unterstützt.
  • Microsoft Windows 8.1 wird nicht mehr unterstützt.
  • Microsoft Office for Mac 2016 wird nicht mehr unterstützt.
  • Oracle Java wird nicht mehr unterstützt.